Windows7 Shares auf Android nicht verfügbar.

  • Antworten:10
  • OffenNicht stickyBentwortet

10.11.2011 21:29:11 via Website

Geschätzte Android-Gemeinde.

Seit Tagen versuche ich vergeblich die Fileshares von meinem Windows 7 Home Premium Rechner auf meinem Android Desire S
oder Acer IconiaTab A500 verfügbar zu machen.

Die Shares von Windows Vista und WindowsXP kann ich ohne Probleme verwenden (Natürlich mit Wlan). Nur die shares von Windows7 gehen nicht.
Das Zugriffsproblem muß also etwas mit Windows7 zu tun haben. Ich weiß aber nicht was ich sonst noch umstellen kann um meine Shares verwenden zu können.

Habe schon zig-Seiten über Samba und Windows7 Zugriff durchgeschmöckert.
Das Forum vom Es File Explorer durchsucht.
Auch in diesem Forum habe ich schon gesucht.
Bisher habe ich keine Zielführende Lösung gefunden.

Alles was ich mache bingt nichts.
( Netzwerk Verbindungen mit 40 bzw. 56 Bit Verschlüsselung statt 128 Bit habe ich unter Erweiterte Netzwerkeinstellungen aktiviert).

Folgende Registrierungskeys habe ich schon umgestellt.
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters]
"DNSNameResolutionRequired"=dword:00000000
"DomainCompatibilityMode"=dword:00000001

HKLM\System\CurrentControlSet\Control\Lsa\LmCompatibilityLevel
HKLM\System\ControlSet001\Control\Lsa\LmCompatibilityLevel

Stehen beide auf 0
0) Send LM & NTLM responses
1) Send LM & NTLM - use NTLMv2 session security if negotiated
2) Send NTLM response only
3) Send NTLMv2 response only
4) Send NTLMv2 response only. Refuse LM
5) Send NTLMv2 response only. Refuse LM & NTLM

Habe eine extra User (als Administrator) angelegt.
Meine Shares für Jeder und den neuen User berechtigt. Aller Dateien auch für Jeder berechtigt.

Habe schon mehrmals gebootet.

Es nützt einfach nichts.

Hat jemand von Euch eine Idee was ich noch unternehmen könnte.

Meine bisherige Suche sagt mir entweder hat keiner sonst den Wunsch Windows7 Shares mit Android zu verwenden, oder es hat keiner eine Lösung.

Vielen Dank für Eure Hilfe.

Lg Helmut

10.11.2011 22:34:54 via Website

Hier stehts wie es funktioniert: http://www.androidpit.de/de/android/forum/thread/414550/Netzwerkfreigaben-SMB-windows-7

In Kürze :
  1. ES Datei Explorer starten
  2. Ganz links oben in der Ecke auf "local" drücken. Es öffnet sich ein Auswahlmenü, in dem du "lan" auswählst.
  3. Im Programmenü "neu" und dann "server" wählen.
  4. Servernamen, Loginnamen und Passwort eintragen. Danach erscheint die neue Verbindung in der Verzeichnisstruktur.
  5. Auf die neue Verbindung klicken, fertig.
Danke an: Breitband kater

Ich hab das ohne weitere Hacks eben selber positiv austesten können.

lg Voss - Ach ja und noch was, die AndroidPIT-Regeln ლ(╹◡╹ლ) Android Security

10.11.2011 23:07:48 via Website

OK,

Kurzes Beispiel:

Auf Laufwerk C:\ gibt es ein Verzeichnis mit namen Netgear, der Pfad : C:\Netgear

Rechte Maustaste im Explorer auf das Verzeichnis und Eigenschaften auswählen, dort den Reiter Freigabe, hier auswählen "Freigabe" dort im Dropdown "Jeder" auswählen und auf hinzufügen klicken, abschließend auf "Fertig" klicken ..

Das war es ..
Nun kann ich im ES Explorer pcname/netgear nach der oben beschriebenen Methode als Freigabe für "anonym" auswählen und wunderbar darauf zugreifen.

Edit: Du solltest sicherstellen, dass du auf dem Netzwerkadapter der am PC verwendet wird, das "Datei und Druckerfreigabe Protokoll" gebunden und aktiviert hast. Sonst wirds nicht funktionieren.

— geändert am 10.11.2011 23:13:55

lg Voss - Ach ja und noch was, die AndroidPIT-Regeln ლ(╹◡╹ლ) Android Security

11.11.2011 08:07:06 via Website

Hallo Jörg.
Das mit der Datei und Druckerfreigabe habe ich noch nicht nachgeschaut. Ist aber ne Idee.
Vielleicht klappt's ja dann. Werde ich am Abend checken.
Hast du Windows7 am PC?
Weil mit Vista und XP funktionierts sowieso.
Danke
Helmut

11.11.2011 09:30:49 via Website

Mein Lappi ist von der Firma, "eigentlich" ohne Beschränkungen. Kann man (Vorbesitzer, nicht mehr ansprechbar) am W7/32 etwas einstellen, da es bei mir nicht verbindet. Am Tab/ES kann man ja nichts verkehrt machen. Netzadresse wird erkannt und eingetragen. Dahinter dann den PC-Namen\freigegebenes Verzeichnis. Wenn man nur das Verzeichnis nimmt was Standard ist sollte man doch die allg. Freigaben sehen. Anmeldename = Adminname und PW ist ja aus dem Lappi ersichtlich.

Natürlicher Verstand kann fast jeden Grad von Bildung ersetzen, aber keine Bildung den natürlichen Verstand. Arthur Schopenhauer App Reviews nach Einsatzzweck und hier noch das: Das-AndroidPITiden-Buch

11.11.2011 10:05:24 via Website

Hallo Jörg.

Vielen Dank für den Tipp.

Der Zugriff bei mir in der Firma funktioniert jetzt.

Offensichtlich war es die Datei- und Druckerfreigabe.
Zuhause kann ich das heute Abend Prüfen.

Einstellungen:

Netzwerkpfad : IP. z.B. 192.168.1.15 (So bekomme ich alle Shares die vorhanden sind)

Benutzername : Es muss ein Lokaler Benutzername sein, (Ohne Domäne)

Passwort : Passwort des Lokalen Benutzers.

Anonym : nicht ankreuzen.

Anzeigen als : Ich nehmen hier immer den Computername + .lan oder .smb.

Helmut

13.11.2011 18:03:36 via Website

Zu Sorry für den verwirrenden letzten Beitrag.
Das Problem mit der Samba (Android) to Windows7 connection hatte ich zuhause. In der Firma habe ich während des Tages getestet, und dort hat es funktioniert sobald ich einen lokalen User verwendet habe. Domain-User gehen offensichtlich nicht. Ist aber kein Problem.

Zuhause hat die Connection nicht funktioniert auch nicht obwohl ich zuhause nur LokaleUser habe.

Mein Betriebssystem Zzuhause ist Windows7 Home Premium. Leider gibt es da die secpol.msc nicht (Locale Sicherheitsrichtlinie gibt es nur auf Windows7 Business und Windows7 Ultimate).

Nach einigen Versuchen habe ich dann das Problem auf Umwegen gefunden und behoben.

Ich hab mal versucht von einem WindowsXP Rechner auf den Windows7 Rechner zu connecten. Ging nicht.
Es kam die Fehlermeldung: Für diesen Befehl ist nicht genügend Serverspeicher verfügbar. Diese Fehler wird sogar im Eventmanager eingetragen, und dir steht auch der IRPStackSize Parameter drin.

Durch diesen Fehler habe ich folgende Registrysetting gefunden und geändert.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters\IRPStackSize (DWord)
Standartwert 20 war anscheinend zu wenig.
Ich habe es auf 80 erhöht.
Danach Reboot.
Und siehe da Zugriff vom Android Handy und TabletPC (Acer Iconia Tab A500) ist möglich.

Problem ist gelöst. Super!!!
Bin Glücklich und zufrieden mit dem Zugriff, brauch kein Kabel mehr und kann von der Couch aus alles machen was ich brauche.

Helmut