(Wear OS) Extrem schlechtes Internet bei Bluetooth-Verbindung

  • Antworten:5
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 4

13.06.2018, 15:39:40 via Website

Hallo,

ist meine Smartwatch via Bluetooth mit dem Smartphone verbunden, funktioniert weder der Google Assistent noch der Playstore.
-> Fehler: "Prüfe ob im WLAN oder mit Smartphone verbunden"

Trenne ich die Bluetooth-Verbindung und die Smartwatch ist via WLAN verbunden, funktioniert sowohl der Google Assistent als auch der Playstore.

Es liegt also an der Bluetooth-Verbindung...

Bisher unternommen:
- Reset SmartWatch
- Akkuoptimierung für alle Google-Services, Wear OS und Bluetooth deaktiviert
- Bluetooth-Thethering aktiviert

In engl. Foren finden sich gleiche Probleme ... aber keine Lösung.

Habt ihr ne Idee?
Liegt's vllt an der Version vom Bluetooth meines Smartphones?

Hardware:
Fossil Q Explorist
(Wear OS 1.2 / Home App 2.12.0.197... / Android 8.0.0.0 / Sicherheitsupdate 02-2018)
Xiaomi Mi A1
(Android 8.0.0 / Sicherheitsupdate 05-2018)
Edit: Bluetooth 4.2, A2DP, LE

— geändert am 13.06.2018, 15:42:50

Diskutiere mit!
  • Forum-Beiträge: 819

14.06.2018, 01:29:18 via Website

Es sieht so aus, als würden sich Bluetooth und WLAN gegenseitig stören, wobei Bluetooth gewinnt.
Bluetooth und WLAN arbeiten beide im 2,4 GHz Band, WLAN kann bei manchen Geräten auch im 5 GHz Band genutzt werden, was aber auch der Router leisten muss.
Dein Gerät könnte auch in 5 GHz Band per WLAN versorgt werden, was möglicherweise das Problem lösen könnte.

https://www.inside-handy.de/handys/xiaomi-mi-a1/daten

Im Prinzip können WLAN und Bluetooth aber auch beide im 2,4 GHz Band betrieben werden. Bluetooth beherrscht "Channelhopping", d.h. es kann schon belegten Kanälen im 2,4 GHz Band ausweichen. Bei Dir scheint das nicht zu funktionieren, was mich vermuten lässt, dass das 2,4 GHz Band durch benachbarte WLAN-Netze, Smarthome-Gerätschaften usw. schon stark belegt ist.

Überprüfen könntest Du das mit einer App wie "WiFi Analyser".
Wenn ich in meiner Vermutung richtig liege, funktioniert der Internetzugang ohne Bluetooth zwar, aber nicht mit hoher Datenrate. Das zugeschalteten Bluetooth kann nicht mehr ausweichen und bringt WLAN vollends zum Erliegen, da es auf die kürzere Distanz trotz kleinerer Sendeleistung "lauter" als der weiter entfernte Accesspoint ist.

Ist das 2,4 GHz Band tatsächlich so voll, wäre es wohl am Besten, mit dem WLAN auf 5 GHz zu wechseln, notfalls auch unter Zukauf eines entsprechenden Accesspoints oder neuen Routers, falls der vorhandene nur auf 2,4 GHz senden kann. Das neue Equipment sollte unbedingt DFS beherrschen, um alle Kanäle auf 5 GHz nutzen zu können.

Ist das nicht möglich oder gewünscht, könntest Du versuchen, am Router einen WLAN-Kanal einzustellen, der durch benachbarte WLANs schon stark belegt ist. Das lokale WLAN müsste sich dann die Bandbreite mit diesen Nachbarnetzen teilen, hätte aber in der eigenen Wohnung die höchste Feldstärke. Wenn Bluetooth nun in benachbarte Kanäle ausweicht, die von weniger starken Nachbarnetzen belegt werden, würden nun zumindest die beiden Sender im eigenen Gerät nicht mehr unmittelbar um die selben Kanäle konkurrieren.

Hast Du die Probleme auch in der Nähe, also vielleicht 2 -3 m Entfernung, von Router? Hier sollte sich das eigene WLAN sowohl gegen benachbarte Netze, als auch gegen das eigene Bluetooth durchsetzen, Bluetooth sich auf anderen Kanälen auch gegen Nachbarnetze.

Die Uhr immer im WLAN-Betrieb ist wohl auch keine Option, da dann die Verbindung abreisst, wenn Du das Haus verlässt.

Quelle: Inside-Handy.de

— geändert am 14.06.2018, 02:22:02

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 4

14.06.2018, 08:59:55 via Website

Edit: Was mich etwas stutzig macht:
Meine Uhr sagt - Bluetooth verbunden
Laut WearOS-App - Bluetooth verbunden
Laut Smartphone - Bluetooth nicht verbunden

Benachrichtigungen kommen aber an !?


Erstmal vielen Dank für die ausführliche Antwort.

Mein Router unterstützt leider kein 5GHz.

Ich habe mal einen Wifi Analyzer laufen lassen - es gibt gerade mal 1 weiteres Netzwerk in der Nähe. Außer meinem TV sendet auch sonst nichts Bluetooth aus. Smarthome-Geräte habe ich auch keine.

Auch direkt neben dem Router funktioniert es nicht.

Momentan ist das WLAN beim Router wie folgt eingestellt (Kanal automatisch):
image

Witzig ist außerdem: Habe ich selbst nur Edge über mobiles Internet, funktioniert das Internet auf der Uhr (langsam, aber es funktioniert)

— geändert am 14.06.2018, 09:08:55

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 819

14.06.2018, 13:06:27 via Website

Normalerweise kooperieren WLAN und Bluetooth auch im 2,4 GHz Band gut. Ich selber streame gelegentlich Musik über WLAN aufs Handy und von dort über Bluetooth zur Stereoanlage, ohne dass es zu Problemen kommt.
Die Protokollstacks dafür werden auch nicht jedes mal neu entwickelt, sondern zugekauft, oder sind schon im OS enthalten, so dass höchstens Implementierungsfehler in Frage kämen, die Stacks selber sollten bewährt sein.
Du könntest trotzdem versuchen ein paar Fragen zu klären.

  • Tritt das Problem nur in Deinem Netzwerk auf, oder auch bei Freunden oder Bekannten? Vielleicht kennst Du auch jemanden mit 5 GHz-WLAN, um zu testen ob das Abhilfe bringen würde.

  • Tritt das Problem nur in Verbindung mit der Uhr auf, oder generell bei der Nutzung von Bluetooth, z.B. in Verbindung mit einem Audioreceiver? Tritt es auch in Verbindung mit der Uhr eines anderen Herstellers auf (Uhr von einem Freund)?

  • Tritt das Problem auch auf, wenn Du die Uhr in Deinem Netzwerk mit einem anderen Handy verbindest, vielleicht dem Gerät eines Freundes oder Bekannten?

  • Lege mal den WLAN-Kanal in Deinem Router fest, statt die automatische Auswahl zu verwenden. Nehme nacheinander die Kanäle 3, 7 und 10 bei jeweils 20 MHz Bandbreite, und überprüfe, ob das Problem dann immer noch auftritt.

Wenn sich das Problem so nicht beheben lässt, dann lässt es sich vielleicht doch eindeutig auf die Uhr oder das Handy als Verursacher festlegen. Vielleicht hat das entsprechende Gerät einen Defekt, oder Uhr und Handy sind aus irgend einem Grund nicht kompatibel.

— geändert am 14.06.2018, 13:20:37

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 4

15.06.2018, 15:05:34 via Website

Sooo Neuigkeiten:

Zum Testen habe ich WLAN auf der Uhr abgeschalten, die Verbindung lief also 100%ig via Bluetooth.

Mit LTE, also mobiles Netz, funktioniert der Google Assistent.

Im WLAN* meiner Freundin funktioniert der Google Assistent ebenfalls.
*2,4GHz, Kanal 11. Fünf weitere WLAN in der Umgebung

Bluetooth vom Smartphone funktioniert generell. Xiaomi MiBand, Auto-Radio, TaoTronics Kopfhörer funktioniert alles ohne Probleme.

Weiteres noch nicht getestet.

Immerhin weiß ich jetzt, das es an meinem WLAN liegt. Kanäle durchtesten mache ich die Tage und berichte.

PS: Bluetooth-Thethering hat damit übrigens nichts zu tun. Die Einstellung deaktiviert sich mit der Zeit sowieso.

— geändert am 15.06.2018, 15:06:32

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 4

21.06.2018, 18:31:13 via Website

Bis heute nicht geschafft.

Google Assistent auf der Smartwatch ist vom Funktionsumfang im Vergleich zum Smartphone aber so eingeschränkt, das er für mich einfach unzureichend ist.

Die Uhr geht zurück und somit gibt es hier leider keine Lösung.

Hilfreich?
Diskutiere mit!

Empfohlene Artikel