Gradle sync failed: Could not find com.android.tools.build:gradle:2.2.3.

  • Antworten:7
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 13

09.03.2018, 18:43:48 via Website

Nach einem update auf Android SDK Version 3.0.1 kommt beim Build ein Fehler

Die App konnte vorher erstellt werden, einfach nach mit dem neuen Android SDK gibt es ein Problem. Gradle 2.2.3 ist bei mir auch nicht installiert.

In workspace.xml sind die Verweise auf Gradle 2.2.3.
die dann den Fehler verursachen.

<option value="$APPLICATION_HOME_DIR$/gradle/m2repository/com/android/tools/build/gradle/2.2.3/gradle-2.2.3.jar"/>

Kann mir da jemand weiter helfen?

Diskutiere mit!
Pascal P.
  • Mod
  • Blogger
  • Forum-Beiträge: 10.169

09.03.2018, 18:52:47 via Website

Hallo Frank,
herzilch Wilkommen hier im Forum :)
Ich habe deinen Thread mal in unseren Entwicklerbereich verschoben ;)

Nutzt du noch Eclipse mit Gradle integration?

Wenn ja, dann solltest du auf AndroidStudio umsteigen, da ist alles viel einfacher...

Zudem würde dir AndroidStudio (AS) auch direkt den Gradle doenload anbieten.

Vieleicht solltest du auch mal gradle updaten. gibt schon v. 4.5: https://gradle.org/releases/

Außerdem sollte deine SDK v. 27 sein: https://developer.android.com/studio/releases/platforms.html

— geändert am 09.03.2018, 18:54:01

LG Pascal //It's not a bug, it's a feature. :) ;)

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 13

09.03.2018, 19:36:52 via Website

Hallo Pascal, vielen Dank :)

Ich verwende:
- Entwicklungsumgebung Android Studio 3.0.1
- Gradle Version: 4.01

Das Problem ist, dass im Quellcode von workspace.xml auf Gradle 2.2.3 referenziert wird, siehe dazu meinen ersten Eintrag oben.

Hier die Fehlermeldung:

19:31 Gradle sync failed: Could not find com.android.tools.build:gradle:2.2.3.
Searched in the following locations:
hteteps:// repo1 .maven.org/maven2/com/android/tools/build/gradle/2.2.3/gradle-2.2.3. pom
hteteps:// repo1 .maven.org/maven2/com/android/tools/build/gradle/2.2.3/gradle-2.2.3. jar
Required by:
sensorapp-android:sensorapp:unspecified
Consult IDE log for more details (Help | Show Log) (20s 63ms)

— geändert am 09.03.2018, 19:47:28

Hilfreich?
Diskutiere mit!
Pascal P.
  • Mod
  • Blogger
  • Forum-Beiträge: 10.169

09.03.2018, 20:59:44 via App

Hmm dann bist du auf dem neusten Stand...
hast du die Workspace.xml mal gesichert und dann gelöscht.
Vlt. hilfts was wenn AS die neu erstellt.

LG Pascal //It's not a bug, it's a feature. :) ;)

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 13

09.03.2018, 22:28:21 via Website

Ja, ich habe jetzt die workspace.xml gelöscht.
Beim Aufruf von Android Studie wurde die workspace.xml wieder neu erstellt und hat wieder auf 2.2.3 referenziert.
hteteps:// repo1 .maven.org/maven2/com/android/tools/build/gradle/2.2.3/gradle-2.2.3. pom

irgendwo muss diese gradle 2.2.3 hinterlegt sein, aber wo?

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 13

09.03.2018, 23:26:50 via Website

Jetzt funktioniert es :)

Ich habe Android SDK Build Tools 26.0.2 installiert UND das Projekt synchronisiert
scheinbar braucht es die Version 26.0.2 zusammen mit Gradle 3.0.1

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 2.902

09.03.2018, 23:29:41 via Website

scheinbar braucht es die Version 26.0.2 zusammen mit Gradle 3.0.1

Richtig , das ist Pflicht.

Das hat er aber bestimmt schon des Öfteren im Log angemeckert ....

Übersehen ?

Liebe Grüße - Stefan
[ App - Entwicklung ]

Hilfreich?
Diskutiere mit!

Empfohlene Artikel