[XSP] Root, CWM & Bootloader

  • Antworten:114
  • OffenNicht stickyBentwortet
  • Forum-Beiträge: 566

08.12.2013 21:31:39 via App

Wenn man flashtool nutzt, sollte man auch die treiber der drivers.exe unter C:\Flashtool\drivers installieren (vorallem flash und fastboot) und danach seinen pc neu starten (auch für einen win8 unerlässlich!)
Danach usb-debug einschalten und handy ausschalten

https://www.milianoids.com
Milianoids - Die Webseite für Sony Xperia Anleitungen, Firmware & Whitepaper !

Bei uns findet ihr alle wichtigen Anleitungen zu Sony Xperia so wie immer aktuelle Firmware und Whitepaper zu allen Modellen die in Europa verfügbar sind​

  • Forum-Beiträge: 36

11.12.2013 16:54:23 via Website

Hi, ich habe es noch mal unter Windows 8 versucht, nachdem ich vom Flashtool alle Treiber installiert habe.
Ich bekomme nun keine Fehlermeldung mehr, jedoch stecke ich es immer "ungewollt" mit USB-Debugging: off an, obwohl die Einstellung auf an steht.
Hier nochmal, ein Auszug:

11/044/2013 16:44:29 - INFO - <- This level is successfully initialized
11/044/2013 16:44:29 - INFO - Flashtool Version 0.9.13.0 built on 2013-06-04 22:50:00
11/044/2013 16:44:45 - INFO - Device connected with USB debugging on
11/044/2013 16:44:53 - INFO - Connected device : Sony Xperia SP
11/044/2013 16:44:53 - INFO - Installed version of busybox : N/A
11/044/2013 16:44:53 - INFO - Android version : 4.1.2 / kernel version : 3.4.0-perf-g1285c6c-01149-g40c437a / Build number : 12.0.A.2.254
11/044/2013 16:44:55 - INFO - Selected XperiaSP_C530X / 12.0.A.1.257 / KernelOnly
11/044/2013 16:44:55 - INFO - Preparing files for flashing
11/044/2013 16:44:56 - INFO - Please connect your device into flashmode.
11/045/2013 16:45:03 - INFO - Device disconnected
11/046/2013 16:46:03 - INFO - Device connected with USB debugging off
11/046/2013 16:46:03 - INFO - For 2011 devices line, be sure you are not in MTP mode
11/046/2013 16:46:50 - INFO - Device disconnected
11/047/2013 16:47:20 - INFO - Device connected with USB debugging off
11/047/2013 16:47:20 - INFO - For 2011 devices line, be sure you are not in MTP mode
11/047/2013 16:47:48 - INFO - Flash canceled


Wie lange muss ich die Leiser-Taste gedrückt halten, während ich das Kabel wieder in den PC stecke?!
Liegt es vielleicht an meinen Handyeinstellungen? Sollte ich vllt mal auf Werkszustand machen (was ich ungern möchte)
oder weißt du vielleicht noch irgendeine Möglichkeit?!

WIe gesagt, das einzige Problem ist, dass er mit USB-debug OFF angeht, wenn ich die Leiser-Taste drücke.
Dieses andere habe ich ausprobiert, habe die APP aber nicht auf dem Handy drauf.
  • Forum-Beiträge: 835

11.12.2013 17:24:07 via Website

11/044/2013 16:44:56 - INFO - Please connect your device into flashmode.
11/045/2013 16:45:03 - INFO - Device disconnected
11/046/2013 16:46:03 - INFO - Device connected with USB debugging off
11/046/2013 16:46:03 - INFO - For 2011 devices line, be sure you are not in MTP mode
11/046/2013 16:46:50 - INFO - Device disconnected
11/047/2013 16:47:20 - INFO - Device connected with USB debugging off
11/047/2013 16:47:20 - INFO - For 2011 devices line, be sure you are not in MTP mode

wenn du in den flashmode gehst, musst du die leisertaste drücken, bis du es angesteckt hast. lass es lieber ein paar sekunden länger gedrückt.
Ich weiß nicht, wiseo mir das vorher nicht aufgefallen ist, aber es scheint als ob du das handy immer schön angehen lässt (es sollte keine minute daern, wenn du es im flashmode verbindest), wenn du es angesteckt hast. Du machst folgendes:
Wenn die oberste zeile wieder kommt, drücke die leiser taste und halte sie gedrückt, bis du das handy erfolgreich angesteckt hast.
dann sollte auch die led-leiste kurz leuchten. danach kannst du los lassen.
Grüße

hier ein ausschnitt aus meiner log. einmal verbnden, dann wieder abgemacht und sofort mit gedrückter leisertaste wieder angsetsckt

11/027/2013 17:27:12 - INFO - <- This level is successfully initialized
11/027/2013 17:27:12 - INFO - Flashtool Version 0.9.11.0 built on 2013-06-04 22:50:00
11/027/2013 17:27:13 - INFO - Device disconnected
11/027/2013 17:27:19 - INFO - Device connected with USB debugging off
11/027/2013 17:27:19 - INFO - For 2011 devices line, be sure you are not in MTP mode
11/027/2013 17:27:20 - INFO - Device connected with USB debugging on
11/027/2013 17:27:20 - INFO - Connected device : Sony Xperia ZL
11/027/2013 17:27:20 - INFO - Installed version of busybox : BusyBox v1.20.2-Stericson (2012-07-04 21:33:31 CDT) multi-call binary.
11/027/2013 17:27:20 - INFO - Android version : 4.2.2 / kernel version : 3.4.0-g43a9ba9 / Build number : 10.3.1.A.2.67
11/027/2013 17:27:20 - INFO - Checking root access
11/027/2013 17:27:21 - INFO - Root Access Allowed
11/027/2013 17:27:45 - INFO - Device disconnected
11/028/2013 17:28:10 - INFO - Device connected in flash mode
11/028/2013 17:28:16 - INFO - Device disconnected
11/028/2013 17:28:34 - INFO - Device connected with USB debugging on
11/028/2013 17:28:34 - INFO - Connected device : Sony Xperia ZL
11/028/2013 17:28:34 - INFO - Installed version of busybox : BusyBox v1.20.2-Stericson (2012-07-04 21:33:31 CDT) multi-call binary.
11/028/2013 17:28:34 - INFO - Android version : 4.2.2 / kernel version : 3.4.0-g43a9ba9 / Build number : 10.3.1.A.2.67
11/028/2013 17:28:34 - INFO - Checking root access
11/028/2013 17:28:35 - INFO - Root Access Allowed

— geändert am 11.12.2013 17:30:45

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 36

11.12.2013 17:37:34 via Website

Am besten erklärst du mir nochmal haargenau wie ich das alles mache, ich beginne ab dem Zeitpunkt wo ich das FLashtool starte und den Blitz drücke..Ab dem Punkt bräuchte ich am besten eine genauere Erklärung.

Aber wieso connected er ohne usb debug?

so mache ich es:
ich drücke den blitz im flashtool, wähle die Datei aus und dann kommt dieses extra fenster was mir sagt dass ich das Handy abstecken soll und mit der "zurück-taste" wieder anstecken soll (habe es aber mit der leister-taste gemacht, anders geht es ja nicht.)
so dann halte ich solange gedrückt bis das Handy am pc wieder dran ist und die led leiste unten grün leuchtet. dann lasse ich los und ein paar Sekunden später kommt im handydisplay der blitz der mir sagt, dass das Handy lädt. gleichzeitig ist im flashtool "usb-debug" off..

komisch alles...
  • Forum-Beiträge: 835

11.12.2013 17:48:34 via Website

Ronni G.
Am besten erklärst du mir nochmal haargenau wie ich das alles mache, ich beginne ab dem Zeitpunkt wo ich das FLashtool starte und den Blitz drücke..Ab dem Punkt bräuchte ich am besten eine genauere Erklärung.

Aber wieso connected er ohne usb debug?

so mache ich es:
ich drücke den blitz im flashtool, wähle die Datei aus und dann kommt dieses extra fenster was mir sagt dass ich das Handy abstecken soll und mit der "zurück-taste" wieder anstecken soll (habe es aber mit der leister-taste gemacht, anders geht es ja nicht.)
so dann halte ich solange gedrückt bis das Handy am pc wieder dran ist und die led leiste unten grün leuchtet. dann lasse ich los und ein paar Sekunden später kommt im handydisplay der blitz der mir sagt, dass das Handy lädt. gleichzeitig ist im flashtool "usb-debug" off..

komisch alles...

ich starte das flashtool und wähle den blitz, dann den ''Flashmode'' und den kernel, ''OK''
Dann kommt das fenster mit der zurücktaste, ich drücke die löeistertaste und halte sie gedrückt.
Dann stecke ich das handy an, während ich die taste gedrückt halte. Ich lasse meistens erst dann los, wenn ich sehe dass sich im fenster etwas bewegt.

Du schaust nochmal in den einstellungen, nicht nur ob du USB Debugging angestellt hast, sondern auch, ob du die Entwicklereinstellungen oben links aktiviert hast.
Dann nochmal auf Xperia-USB-Verbindung-Modus-Massenspeichermodus
Dann sollte es gehen. wenn nicht, muss es an treibern liegen, welche du ja nochmal installiert hast, an windows acht (nutze halt windows sieben) oder am flashtool selbst, ich verwende version 0.9.11.0

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 36

11.12.2013 20:16:36 via Website

Ich melde mich die Tage nochmal, ich werde mir Windows 7 wieder auf den Laptop ziehen (komme ich besser klar) und dann werde ich das ganze noch mal versuchen, ansonsten könntest du mir deine Flashtool-Version ja mal hochladen oder so, oder?!

Denn so wie du es beschrieben hast habe ich es versucht und auch vorher so gemacht, dann wird es wohl an der Windows 8 Version liegen.
  • Forum-Beiträge: 835

12.12.2013 07:32:41 via App

hoffen wir es :)
Ja ich bin zwar über das Wochenende nicht da aber im Notfall kannst du mir eine PN schicken und ich helfe dir dann über hangouts oder Whatsapp
Grüße

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

Gelöschter Account
  • Forum-Beiträge: 4

30.12.2013 11:16:16 via Website

Kann es sein das der ClockworkMod nach der Installation von CyanogenMod gelöscht wird?

Wollte mir das Basis GAPPS Paket via ClockworkMod Recovery installieren. (Habe es nicht gleichzeitig mit dem CyanogenMod installiert.)

Jetzt habe ich es versucht nach der Anleitung von dir aus diesem Thread zu installieren, hat aber nicht funktioniert. In der cmd.exe steht zwar Erfolgreich, (manchmal aber auch nicht), es installiert aber nicht. Hatte mein Virusschutzprogramm ausgeschaltet. USB Debuging eingeschaltet.

Kann es vielleicht nicht unter CyanogenMod installiert werden?

Warscheinlich schon. Sonst kann man ja nicht auf andere ROMs wechseln.
Gelöschter Account
  • Forum-Beiträge: 4

30.12.2013 11:46:53 via Website

Problem erledigt, man muss scheinbar Power und Vol+ gleichzeitig drücken..

Ja, das ist schon etwas peinlich :*) :lol:

— geändert am 30.12.2013 11:47:23

  • Forum-Beiträge: 835

30.12.2013 21:21:42 via App

A.Schreier
Problem erledigt, man muss scheinbar Power und Vol+ gleichzeitig drücken..

Ja, das ist schon etwas peinlich :*) :lol:
quatsch das ist nicht peinlich.. die Anleitung zum installieren gilt für den stock Kernel. andere kernel, wie der von cm haben die recovery integriert.
Du müsstest sie aber auch nur durch drücken einer Lautstärke taste erreichen können
grüße

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 4

12.01.2014 18:29:33 via Website

Hallo!

Habe mein Sp gerootet. NUn würde ich gerne Android 4.3 und CM 10.2 aufspielen. Hat jemand eine Quelle wo ich diese beziehen kann?

lg
  • Forum-Beiträge: 835

13.01.2014 06:21:44 via App

Bitte hier:
http://forum.xda-developers.com/showthread.php?t=2599655

und hier ist sogar 4.4 Kit kat ;)
http://forum.xda-developers.com/showthread.php?t=2599650

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 4

13.01.2014 11:26:39 via Website

Hi!

Vielen Dank! Habe jetzt den kompletten Zip-Ordner auf die Speicherkarte gezogen. Jedoch kann ich es nicht installieren. Muss ich die Sd vorher Rootfähig machen? Wenn ja wie mache ich das weil ich habe kein Kartenleser. Geht das auch wenn die Karte im Handy steckt?
Sry das ich soviel frage aber das ist komplettes Neuland:)
  • Forum-Beiträge: 835

13.01.2014 17:39:02 via App

du musst den bootloader entsperren. einen thread dazu findest du auch in der custom Rom und modding section

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 4

13.01.2014 18:25:15 via Website

hab ich ja schon alles gemacht.wenn ich jetzt ins rootmenü starte ,bekomme ich aber nicht die mod angezeigt. habe wie gesagt den ganzen gezipten ordner draufgezogen
  • Forum-Beiträge: 835

13.01.2014 21:32:29 via App

hm du musst in der recovery auf install top from EXTERNAL sdcard gehen?
Dann sollte er dir jede zip anzeigen die da ist...

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 4

14.01.2014 00:29:41 via Website

Hey!

Vielen lieben Dank. Das war der entscheidende Tipp:)
Nun hat alles bestens funktioniert.

Vielen Dank nochmal

lg
  • Forum-Beiträge: 6

13.02.2014 15:23:25 via Website

[Zitat gelöscht]


Hi!
Habe wirklich alles so gemacht wie du es beschrieben hast Kai...hat auch alles so gefunzt wie du es beschrieben hast, bis auf eines... :(

Ich habe kein Super SU und kein BusyBox... -.-

Hast du eine Ahnung?... :(

Würde mich RIIIIIEEESSIIIGG Freuen!!

— geändert am 15.02.2014 13:29:06

  • Forum-Beiträge: 835

13.02.2014 15:51:27 via App

ja ich helfe dir gerne, aber bitte bearbeite deinen Beitrag und entferne das Zitat des eröffnenden Posts :)

es kommt vor, dass es manchmal einfach nicht funktioniert... hast du den Bootloader entsperrt?
auf jeden Fall sollte das Problem sich gelöst haben, wenn du es einfach noch mal probierst :)
achte bitte akkurat darauf, dass jeder Schritt stimmt... falls es danach immer noch nicht funktioniert, schreibe mir mal deine genaue Versionsnummer auf.
wenn das installieren des cwm geklappt hat, kann es sein dass der root potentiell da ist, aber supersu fehlt. suche einfach supersu im play store
liebe Grüße

— geändert am 13.02.2014 15:59:01

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 6

15.02.2014 13:30:44 via Website

Danke. Sorry das ich nicht zurück geschrieben hab. War auf Geschäftsreise. Ich werde gleich mal das mit dem Play Store und SuperSU machen! Den Bootloader habe ich nicht Unlockt. Ist das schlimm?
Danke vielmals. Wenn das nicht klappt mach ich wie beschrieben. Danke!!

— geändert am 15.02.2014 13:34:09