Samsung Galaxy S — Hoher Stromverbrauch durch Android.System Prozess

  • Antworten:7
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 11

19.11.2010, 12:49:28 via Website

Hallo,

mir geht es genauso wie vielen anderen Foren-Mitglieder, dass nach Froyo-Update der Stromverbrauch des SGS gefühlt höher ist als vorher. Habe jetzt versucht, dies genauer zu analysieren, und mir auch das Tool "System Panel" mit Monitoring angeschafft.

Natürlich haben die verschiedensten Einstellungen Einfluss auf den Akku-Verbrauch, wie WLAN, Bluetooth, Datentraffic etc. Was mir aber aufgefallen ist und ich nicht verstehe, dass schlussendlich der Prozess "Android.System" extrem unterschiedlich im Stromverbrauch ist, bei exakt gleichen Einstellungen. Ich habe meistens über Nacht im Standby gemessen. Einmal ist die CPU-Belastung des Prozesses gering bei ca. 0.5-0.8%, was einen Akkuverbrauch von ca. 2-3% über 8h ergibt. Ein anderes Mal bei exakt gleichen Settings bei den Hauptverbrauchern (WLAN, Datentraffic, Pushmail .....alles Off) ist die CPU-Belastung über Nacht ca. 5-10%, was einem Akkuverbrauch von ca. 25-30% innerhalb von 8h im Standby ergibt. Damit ist der Akku dann natürlich ohne Benutzung(!) innerhalb eines Tages praktisch leer.

Leider ist keine Reproduzierbarkeit erkennbar. Der Verbrauch springt auch relativ stark. Ich habe einmal kurz den Datennetzmodus ein- und wieder ausgeschaltet, wodurch sich die durchschnittliche CPU-Belastung von 5% auf 0,5% und auch der Stromverbrauch stark reduziert hat. Ich kann leider die eigentliche Ursache nicht herausfinden. Gemessen habe ich immer mindestens über 4 Stunden und immer im Standby-Modus um hier einen vernünftigen Durchschnittswert zu bekommen.

Gibts wem, der ähnliches analysiert hat und vielleicht auch schon eine Lösung hat.

Interessanterweise habe ich bemerkt, dass der Prozess für den Lagesensor (sensorserver_ya) auch viel Strom verbraucht. Wenn ich die Autorotation ausschalte (über Benachrichtungs-Panel), sinkt die durchschnittliche CPU-Belastung gleich messbar ab, und der Stromverbrauch natürlich abenso. Strange! Auto-Synchronisation und Push-Mail sind natürlich auch große Stromverbracher.

Würde mich freuen, hier ein paar Erkenntnisse zusätzlich zu gewinnen. Mit Stabiltät und Geschwindigkeit bin ich im Großen und Ganzen mit Froyo recht zufrieden.

Antworten
  • Forum-Beiträge: 2

13.12.2010, 14:42:45 via Website

Hallo,

hab das selbe Problem!
Nach dem Update auf Froyo war bei mir tlw. der Akku über Nacht (!) leer.
Hab mit dem "System Monitor" (super App!) herausgefunden, dass der System-Prozess zwischen 20 und 30% CPU-Last erzeugt, permanent!

Der Verursacher hierfür ist (bei mir) das syncen vom Kalender mit unserem Exchange Server.
Sobald ich die Kalender-Sync abschalte (NICHT den Email-Sync, der bleibt auf Push!), hält der Akku locker 2 Tage durch.

Ist schon seltsam, mit 2.1 war's nicht halb so schlimm!?
Gibt's da vielleicht irgendein Fix? Brauch den Kalender dienstlich :-(

— geändert am 13.12.2010, 14:43:31

Antworten
  • Forum-Beiträge: 76

13.12.2010, 15:32:55 via Website

Ich hab seit 2 Tagen 2.2.1 drauf.
Ebenfalls synchronisiere ich Kalender, Mail und Kontakte mit dem Exchange-Server in unserer Firma.
Die gesamte Grundlast aller Prozesse im Leerlauf liegt bei mir zwischen 1 und 3 %. (Laut System Monitor, wirklich eine SuperApp!)
Wie es mit 2.2 war weiß ich nicht, da hatte ich noch keinen SystemMonitor.

Antworten
  • Forum-Beiträge: 77

15.12.2010, 08:36:54 via Website

Hallo,

da es im Markt ja mehrere System Monitore gibt, wollte ich mal fragen, welchen Ihr denn genau nutzt?

Antworten
  • Forum-Beiträge: 76

15.12.2010, 09:52:49 via Website

Andreas S.
Hallo,

da es im Markt ja mehrere System Monitore gibt, wollte ich mal fragen, welchen Ihr denn genau nutzt?
"SystemPanel" von NextApp

Antworten
  • Forum-Beiträge: 2

24.12.2010, 15:23:23 via Website

So!
Hab den Stromfresser gefunden :)

Nachdem ich das synchen des Exchange-Kalenders abgeschaltet hab (nicht das Email syncen, das hab ich auf Push gelassen),
hielt der Akku wieder wie gewohnt 1,5 bis 2 Tage durch!

Hab dann mein Exchange-Konto komplett gelöscht und neu eingerichtet. Seitdem ist der Stromverbrauch auch mit Kalender-Sync wieder ok :D

Antworten
  • Forum-Beiträge: 1

27.12.2010, 00:19:37 via Website

Hey. Hab fast das selbe Problem.

So vor ner Woche bemerkte Ich, dass Ich nur soch so rund 16 Stunden Batterie habe.


Mit watchdog habe ich festgestellt, dass einzig "android system" immer so um 30% rumdümpelt.

Hab factory reset gemacht und nun ist es "android media process" das um die 45% läuft wobei system noch bei 20% ist.


Hat jemand ne Idee?

Antworten

Empfohlene Artikel