Update Android Studio Update 3.1.2 nach 3.4.1

  • Antworten:10
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 73

01.07.2019, 15:42:26 via Website

Hallo,

ich habe ein Update eingeleitet mit Download, entpacken usw.
zum Schluß erhielt ich eine Übersicht mit 7 Zeilen folgender Art:
gradle/gradle-5.1.1/....
bei allen stand noch am Ende:
Action:Update Problem:Absent Solution:NONE
dazu kam nur noch ein Button Cancel
Das Übersichtbild habe ich angefügt.

User uploaded photo

Bitte um Hinweise !
Gruß Wicki

Diskutiere mit!
  • Forum-Beiträge: 73

05.07.2019, 15:01:55 via Website

Ich habe inzwischen Folgendes gemacht:
- AS deinstalliert (uninstall.exe)
- Download 3.4.1
- .android und .gradle (dauerte sehr lange) im User-Verzeichnis gelöscht
- neues AS installiert
Ergebnis: läuft zunächst

Problem: ein Mapquest-Projekt, das bisher lief, kann ich unter 3.4.1 nicht mehr zum Laufen bringen
Hier die Fehlerausschriften:
Could not find com.mapquest:mapping-android-sdk:1.3.2.
Searched in the following locations:
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/m2repository/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/m2repository/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.aar
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/google/m2repository/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/google/m2repository/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.aar
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/android/m2repository/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/android/m2repository/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.aar
https://jcenter.bintray.com/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.pom
https://jcenter.bintray.com/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.aar
http://artifactory.cloud.mapquest.com/artifactory/et-android-binaries/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.pom
http://artifactory.cloud.mapquest.com/artifactory/et-android-binaries/com/mapquest/mapping-android-sdk/1.3.2/mapping-android-sdk-1.3.2.aar
Required by:
project :app

Dazu meine build.gradle:

apply plugin: 'com.android.application'

android {
compileSdkVersion 26
buildToolsVersion "27.0.3"
defaultConfig {
applicationId "example.com.mymapquestapp"
minSdkVersion 16
targetSdkVersion 26 //16
versionCode 1
versionName "1.0"
testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
}
//https://stackoverflow.com/questions/48709870/still-getting-warning-configuration-compile-is-obsolete-and-has-been-replace
//in Android Studio version 3.1 dependencies compile word is replaced to implementation
//dadurch vermeiden der 5 obsolete-Warnungen durch den Compiler
dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
androidTestImplementation('com.android.support.test.espresso:espresso-core:2.3-alpha', {
exclude group: 'com.android.support', module: 'support-annotations'
})
// compile 'com.android.support:appcompat-v7:26.1.0'
testImplementation 'junit:junit:4.13-beta-3'
implementation('com.mapquest:mapping-android-sdk:1.3.2@aar') {
transitive = true
}
}
android {
compileOptions {
sourceCompatibility JavaVersion.VERSION_1_8
targetCompatibility JavaVersion.VERSION_1_8
}
}

/**********************/
Bitte um Hilfe !
Gruß Wicki

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 775

05.07.2019, 15:30:01 via Website

Hallo
Erstmals solltest du schauen du überhaupt das SDK für API 26 Installiert hast sieht mir nicht so aus .
Schaue mal in den SDK Manager.

Dann willst du „buildToolsVersion "27.0.3"“ benutzen dazu müsste das auch vorhanden sein und ich glaube auch das SDK 27 auch vorhanden sein sollte.

Das alles ist bei einem Standard Android Studio nicht installiert.

Ich würde die Zeile mit der buildToolsVersion im Gradle weg lassen. Dann wird automatisch die neuste genommen.
Es könnte auch sein das bei Version 27.0.3 die neue Gradle Version 5.x nicht läuft.

auch würde ich eine neuere Version benutzen und keine

implementation('com.mapquest:mapping-android-sdk:2.0.10')

https://developer.mapquest.com/documentation/maps-sdk/android/v2.0.10/

— geändert am 05.07.2019, 16:31:07

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 73

05.07.2019, 22:12:59 via Website

Danke Jokel !
- habe buildToolsVersion weggelassen
- API 26 ist partially installed
- Änderung : implementation('com.mapquest:mapping-android-sdk:2.0.10')

Neue Fehlermeldungen:
Could not find com.android.support:support-annotations:27.1.1.
Searched in the following locations:
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
https://jcenter.bintray.com/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
https://jcenter.bintray.com/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
http://artifactory.cloud.mapquest.com/artifactory/et-android-binaries/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
http://artifactory.cloud.mapquest.com/artifactory/et-android-binaries/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
Required by:
project :app > com.mapquest:mapping-android-sdk:2.0.10 > com.mapbox.mapboxsdk:mapbox-android-sdk:6.2.0

Please install the Android Support Repository from the Android SDK Manager.
Open Android SDK Manager
** Ende Fehlerprotokoll **
Im SDK Manager habe ich "Android Support Repository" nicht gefunden !

Gruß Wicki

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 775

06.07.2019, 11:26:31 via Website

Hallo
Die Versions Nummer der Support Libs und die „compileSdkVersion“ müssen übereinstimmen.

In deinem buildGradle hast du compileSdkVersion 26 und deine Supportlib ist 27 das geht nicht.
Das hattest du in deinem ersten Ggradle richtig.

Auch sollte folgende Zeile im Projekt Gradle File sein.
maven { url 'https://artifactory.cloud.mapquest.com/artifactory/et-android-binaries' }

habe dir ja den link gegeben wo drin stet wie du es in dein Projekt einbindest.

PS.
auch für deine mapbox gibt es eine neurere Version.

 implementation  group: 'com.mapbox.mapboxsdk', name: 'mapbox-android-sdk', version: '8.1.0'

https://mvnrepository.com/artifact/com.mapbox.mapboxsdk/mapbox-android-sdk

— geändert am 06.07.2019, 12:22:35

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 73

06.07.2019, 14:14:12 via Website

Danke für Deine Mühe !
Ich habe noch Probleme mit einigen Deiner Hinweise.

  • die maven-Zeile im Projekt Gradle File ist schon immer vorhanden
  • ich finde keine SupportLib 27, die einzige 27 steht in der buildToolsVersion-Zeile und die ist auskommentiert wie von Dir empfohlen

Im nachfolgenden Textblock sind enthalten:
build.gradle für Projekt und App, Fehlermeldungen für Sync- und Build-Vorgang.

************* build.gradle, Projekt ***************
// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
repositories {
jcenter()
google()
}
dependencies {
classpath 'com.android.tools.build:gradle:3.1.2'

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}

}

allprojects {
repositories {
jcenter()
// mq maven repo
maven { url 'http://artifactory.cloud.mapquest.com/artifactory/et-android-binaries' }
}
}

task clean(type: Delete) {
delete rootProject.buildDir
}

************ build.gradle, app **************
apply plugin: 'com.android.application'

android {
compileSdkVersion 26
/* buildToolsVersion "27.0.3" /
defaultConfig {
applicationId "example.com.mymapquestapp"
minSdkVersion 16
targetSdkVersion 26
versionCode 1
versionName "1.0"
testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
}
//https://stackoverflow.com/questions/48709870/still-getting-warning-configuration-compile-is-obsolete-and-has-been-replace
//in Android Studio version 3.1 dependencies compile word is replaced to implementation
//dadurch vermeiden der 5 obsolete-Warnungen durch den Compiler
dependencies {
implementation fileTree(dir: 'libs', include: ['
.jar'])
androidTestImplementation('com.android.support.test.espresso:espresso-core:2.3-alpha', {
exclude group: 'com.android.support', module: 'support-annotations'
})
// compile 'com.android.support:appcompat-v7:26.1.0'
testImplementation 'junit:junit:4.13-beta-3'
// implementation('com.mapquest:mapping-android-sdk:1.3.2@aar') {
// transitive = true
// }
implementation('com.mapquest:mapping-android-sdk:2.0.10')
implementation group: 'com.mapbox.mapboxsdk', name: 'mapbox-android-sdk', version: '8.1.0'
}
android {
compileOptions {
sourceCompatibility JavaVersion.VERSION_1_8
targetCompatibility JavaVersion.VERSION_1_8
}
}

************ sync Fehler **************
CONFIGURE SUCCESSFUL in 11s
ERROR: Failed to resolve: com.android.support:support-annotations:27.1.1
Add Google Maven repository and sync project
Show in Project Structure dialog
Affected Modules: app

ERROR: Failed to resolve: com.android.support:support-fragment:27.1.1
Add Google Maven repository and sync project
Show in Project Structure dialog
Affected Modules: app

ERROR: Failed to resolve: android.arch.lifecycle:livedata:1.1.1
Show in Project Structure dialog
Affected Modules: app

ERROR: Failed to resolve: com.android.support:support-compat:27.1.1
Add Google Maven repository and sync project
Show in Project Structure dialog
Affected Modules: app

ERROR: Failed to resolve: com.android.support:multidex:1.0.2
Add Google Maven repository and sync project
Show in Project Structure dialog
Affected Modules: app

ERROR: Failed to resolve: com.android.support:support-core-utils:27.1.1
Add Google Maven repository and sync project
Show in Project Structure dialog
Affected Modules: app

************ build Fehler **************
Could not find com.android.support:support-annotations:27.1.1.
Searched in the following locations:
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
https://jcenter.bintray.com/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
https://jcenter.bintray.com/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
http://artifactory.cloud.mapquest.com/artifactory/et-android-binaries/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.pom
http://artifactory.cloud.mapquest.com/artifactory/et-android-binaries/com/android/support/support-annotations/27.1.1/support-annotations-27.1.1.jar
Required by:
project :app > com.mapbox.mapboxsdk:mapbox-android-sdk:8.1.0
project :app > com.mapbox.mapboxsdk:mapbox-android-sdk:8.1.0 > com.mapbox.mapboxsdk:mapbox-android-telemetry:4.5.1
project :app > com.mapbox.mapboxsdk:mapbox-android-sdk:8.1.0 > com.mapbox.mapboxsdk:mapbox-android-accounts:0.2.0

Please install the Android Support Repository from the Android SDK Manager.
Open Android SDK Manager

— geändert am 06.07.2019, 14:17:35

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 775

06.07.2019, 16:03:01 via Website

also ich sagte.

Die Versions Nummer der Support Libs und die „compileSdkVersion“ müssen übereinstimmen.

tuen sie bei dir nicht.

wenn du unter SDK 26 schreiben willst musst du auch die Support Lib 26 benutzen

implementation 'com.android.support:appcompat-v7:26.1.0'

eine 27 geht nicht.

Jetzt noch mal „compileSdkVersion 26“ und appcompat-v7:26.1.0 gehören zusammen.

Die "buildToolsVersion" ist wider was anderes.
Wenn keine Angabe da ist wird sie automatisch bestimmt. Das ist nur in bestimmten fällen sinnvoll.

apply plugin: 'com.android.application'

android {
compileSdkVersion 26
defaultConfig {
applicationId "com.example.myapplication"
minSdkVersion 15
targetSdkVersion 26
versionCode 1
versionName "1.0"
testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
}
}
}

dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
//noinspection GradleCompatible
implementation 'com.android.support:appcompat-v7:26.1.0'
implementation 'com.android.support.constraint:constraint-layout:1.1.3'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.android.support.test:runner:1.0.2'
androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'

implementation 'com.mapquest:mapping-android-sdk:2.0.10'
implementation  group: 'com.mapbox.mapboxsdk', name: 'mapbox-android-sdk', version: '8.1.0'

}

— geändert am 06.07.2019, 16:37:40

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 775

06.07.2019, 16:24:00 via Website

ich sehe gerade das du auch deine SupportLib in Kommentar hast was soll das?
// compile 'com.android.support:appcompat-v7:26.1.0'

das was du da hattest ist kein fehler sondern ein hinweis das "compile" nicht mehr verwendet werden soll.
Und du "implementation" benutzen sollst.

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 73

06.07.2019, 18:42:42 via Website

Dank für Deine Mühe !
Leider funktioniert es noch immer nicht.

Es folgen meine build.gradle für die app und das Fehlerprotokoll zu "MyMapquestApp: sync failed".

********* build.gradle, app *************

apply plugin: 'com.android.application'

android {
compileSdkVersion 26
/* buildToolsVersion "27.0.3" */
defaultConfig {
applicationId "example.com.mymapquestapp"
minSdkVersion 16
targetSdkVersion 26
versionCode 1
versionName "1.0"
testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
}
}
}

dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation 'com.android.support:appcompat-v7:26.1.0'
implementation 'com.android.support.constraint:constraint-layout:1.1.3'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.android.support.test:runner:1.0.2'
androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
implementation('com.mapquest:mapping-android-sdk:2.0.10')
implementation group: 'com.mapbox.mapboxsdk', name: 'mapbox-android-sdk', version: '8.1.0'
}
android {
compileOptions {
sourceCompatibility JavaVersion.VERSION_1_8
targetCompatibility JavaVersion.VERSION_1_8
}
}

********* Fehlerprotokoll *************
Could not find com.android.support:appcompat-v7:26.1.0.
Searched in the following locations:
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/m2repository/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/m2repository/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.jar
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.jar
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.pom
file:/C:/Users/Ad/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.jar
https://jcenter.bintray.com/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.pom
https://jcenter.bintray.com/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.jar
https://artifactory.cloud.mapquest.com/artifactory/et-android-binaries/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.pom
https://artifactory.cloud.mapquest.com/artifactory/et-android-binaries/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.jar
Required by:
project :app

Please install the Android Support Repository from the Android SDK Manager.
Open Android SDK Manager

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 775

06.07.2019, 19:40:04 via Website

Nun wird es lamgsam mal Zeit das du zeigst wie dein sdk Manager aussieht.

Ps bei mir geht das mit meinen grade File.

Wenn du wirklich auch sdk 26 im sdk Manager installiert hast stimmt etwas mit deinem Studio nicht.

— geändert am 06.07.2019, 19:46:26

Hilfreich?
Diskutiere mit!
  • Forum-Beiträge: 73

06.07.2019, 20:40:57 via Website

Danke, Ausschnitt SDK-Manager:

API Level 26, Revision 2: Partially installed
API Level 16, Revision 5: Update available
API Level 21, Revision 2: Update available

Ein anderes altes Projekt konnte ich unter dem neuen AS erfolgreich installieren und abarbeiten.

Gruß Wicki

Hilfreich?
Diskutiere mit!