Gradle Build laüft endlos

  • Antworten:2
  • OffenNicht stickyBentwortet
  • Forum-Beiträge: 67

07.04.2018, 21:14:40 via Website

Die App funktionierte schon mal, die zugehörige apk-Datei habe ich noch. Nun
möchte ich die App etwas verändern und aus mir unersichtlichen Gründen kann ich
sie jetzt nicht mehr neu installieren (auch ohne die beabsichtigten Änderungen).
Beim Projektstart (mit Android Studio) läuft Gradle Build normal und ohne Fehler:

  • Gradle Build
    18:43:51 Gradle sync started
    18:45:32 Gradle sync completed

Wenn ich die App nun starten und sie auf meinem Smartphone installieren will
passiert folgendes:

18:45:34 Executing tasks: [:app:generateDebugSources, :app:mockableAndroidJar,
:app:prepareDebugUnitTestDependencies, :app:generateDebugAndroidTestSources]
18:45:55 Gradle build finished in 22s 740ms
18:46:20 Executing tasks: [:app:clean, :app:generateDebugSources, :app:mockableAndroidJar,
:app:prepareDebugUnitTestDependencies, :app:generateDebugAndroidTestSources, :app:assembleDebug]
** nach 4 Minuten: cannot resolve symbol R.xxxx
** läuft nach 14 Min. immer noch und lässt sich nur mit dem Taskmanager beenden.

  • Gradle console:
    Executing tasks: [clean, :app:generateDebugSources, :app:mockableAndroidJar,
    :app:prepareDebugUnitTestDependencies, :app:generateDebugAndroidTestSources,
    :app:compileDebugSources, :app:compileDebugUnitTestSources,
    :app:compileDebugAndroidTestSources]

    Configuration on demand is an incubating feature.
    Incremental java compilation is an incubating feature.
    :clean UP-TO-DATE
    :app:clean

Datei Build.gradle:
apply plugin: 'com.android.application'
android {
compileSdkVersion 21
buildToolsVersion "21.1.2"
defaultConfig {
applicationId "de.carpelibrum.direseasy"
minSdkVersion 16
targetSdkVersion 16
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
}
}
}

Datei AndroidManifest:

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="de.carpelibrum.direseasy"
    android:versionCode="1"
    android:versionName="1.0" >
    <uses-sdk android:minSdkVersion="16" />
    <uses-permission android:name="android.permission.INTERNET" />
    <uses-permission android:name="android.permission.ACCESS_WIFI_STATE" />
    <uses-permission android:name="android.permission.CHANGE_WIFI_STATE"/>
    <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"/>
    <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
    <application
        android:icon="@drawable/ic_launcher"
        android:label="@string/app_name" >
        <activity
            android:name=".TestActivity"
            android:label="@string/app_name" >
            <intent-filter>
                <action android:name="android.intent.action.MAIN" />
                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>
        </activity>
        <activity
                android:name=".DownloadAsyncActivity">
      </activity>
<!--        <receiver android:name="MyReceiver" >
            <intent-filter>
                <action android:name="de.vogella.android.mybroadcaster" />
            </intent-filter>
        </receiver> -->
        <service android:name=".LocalService" android:exported="false" />
    </application>
</manifest>

Zusammenfassung:
- Gradle Build läuft scheinbar endlos
- einige Zeit nach Beginn können R-Symbole nicht mehr zugeordnet werden

Diskutiere mit!
Beste Antwort
  • Forum-Beiträge: 2.902

08.04.2018, 00:07:06 via Website

Hallo Wickki11,

mach mal ein ordentlichen Clean / Rebulid und Invalidate Caches

Und was dann der AS als Änderung vorschlägt - ALLES auch wirklich ALLES abarbeiten.
Es hat sich zur neusten Version viel geändert.

Ansonsten : Mach dir ein leeres Projekt und nimm die paar Files rüber.
Das Ding scheint ja nicht gross zu sein - kostet dich 5 Min

— geändert am 08.04.2018, 00:07:40

Liebe Grüße - Stefan
[ App - Entwicklung ]

Hilfreich?
Ni9e, Pascal P. und 1 mehr Ni9ePascal P.Wicki11
Diskutiere mit!
  • Forum-Beiträge: 67

08.04.2018, 15:48:55 via Website

Hallo swa00,
besten Dank, es läuft wieder. Ich habe das AS-Update (sehr umfangreich) gemacht und den "Invalidate Caches / Restart".
Das Clean / Rebuild und das Anlegen eines neuen Projekts hatte ich vorher schon versucht aber ohne Erfolg.

Gruß Wicki

Hilfreich?
Diskutiere mit!

Empfohlene Artikel