Xperia-Rettung

  • Antworten:39
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 3

09.02.2014 20:15:23 via Website

Hi,

ein Sony SP, C5303. Hat sich aber alles gefunden. Hatte nur angst vor der falschen ROM, aber ein anderer hat in dem verlinkten Forum die selbe Frage gestellt...
  • Forum-Beiträge: 6

10.02.2014 15:14:40 via Website

Sorry das ich hier in das Thema platze, doch das sehen viele leute...
Könnte mir jemand eine gute Anleitung zum Booten meines Sony Xperia SP geben?

In den Threads die ich eröffnet habe kommt leider keine Antwort... :/
Würde mich Freuen! Am besten mit Direkten Links zu den Seiten der Treiber und des Programms...!
Vielen dank! Ich zähle auf euch! :)
  • Forum-Beiträge: 835

11.02.2014 06:30:37 via App

NightMare Tx
Sorry das ich hier in das Thema platze, doch das sehen viele leute...
Könnte mir jemand eine gute Anleitung zum Booten meines Sony Xperia SP geben?

In den Threads die ich eröffnet habe kommt leider keine Antwort... :/
Würde mich Freuen! Am besten mit Direkten Links zu den Seiten der Treiber und des Programms...!
Vielen dank! Ich zähle auf euch! :)
Booten mit der an/Aus Taste

für rooten schau einfach mal in der Kategorie root und custom roms für das Xperia sp.
Es tut mir leid dass ich jetzt mal ein machtwort spreche,aber es kommt mit vor als nutze hier niemand die sufu-.-
es ist doch alles da!

— geändert am 11.02.2014 06:31:02

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 29

14.02.2014 13:30:54 via Website

Ich habe nun schon etliche Threads zum Rooten durchgelesen, ich habe bei meinem XZ das Rooten auch schon erfolgreich hinbekommen.
nun wollte ich vor einigen Wochen nicht mehr auf das Rollout von 569 warten und habe die pre-rooted 569 von NUT genommen (Journalists).
Im Recovery ein Backup gemacht.

Beim Flashen ist dann irgendwas schief gelaufen, ich hin im Bootloop. Das einzige, was mein Ding wieder zum laufen brachte, war das flashen der .569 als FTF. Hat natürlich kein Root und kein Custom Recovery.

Korrigiert mich, wenn ich das nun falsch sehe:
- ich selber habe den Bootloader nicht geöffnet, BA2 und DRM-Schlüssel entsprechend nichts geändert (*#*#7378423#*#* -> Service Info -> Configuration -> Bootloader unlock allowed: yes, das stand aber von Anfang an drin, Gerät im freien Handel erworben)
- wenn ich rooten will, muss ich den Bootloader öffnen
- Konsequenz: ich verliere BA2 und DRM
- Will ich TA Backup ausführen, um BA2 und DRM zu sichern, brauche ich Root

Beißt sich die Katze in den Schwanz?

Was ich bisher (erfolglos) probiert habe:

- .67 per Flashtool bespielen sowie stripped .67-Kernel (welches ja rootbar ist, das war meine letzte Version vor der .569)
- auch vorhergehende Versionen aufgespielt (.244), ebenfalls ohne Ergebnis
-> Resultat ist immer ein Dauerloop, wahlweise nur das Sony-Logo (.244) oder zumindest bis zur farblichen Animation (.67), danach Reboot

Wer kann mir einen Tipp geben? Das Leben ohne Root ist ziemlich nervend, speziell, da XPosed nicht genutzt werden kann.
  • Forum-Beiträge: 835

14.02.2014 15:44:16 via Website

Dirk B.

- ich selber habe den Bootloader nicht geöffnet, BA2 und DRM-Schlüssel entsprechend nichts geändert (*#*#7378423#*#* -> Service Info -> Configuration -> Bootloader unlock allowed: yes, das stand aber von Anfang an drin, Gerät im freien Handel erworben)Der Bootloader ist noch gresperrt...
- wenn ich rooten will, muss ich den Bootloader öffnenFalsch. Im Prinzip flashst du den Kernel einer älteren Firmware (in deinem Fall dann wahrscheinlich .67), welcher rootbar ist und rootest, dann flashst du wieder den Kernel der neueren Firmware. Das ist bei allen 2013 Gewräten von Sony so.
- Konsequenz: ich verliere BA2 und DRM Auf der offiziellen Rom ja, in diversen Custom Roms (eXistenZ) sind sie enthalten
- Will ich TA Backup ausführen, um BA2 und DRM zu sichern, brauche ich Root Exakt


Im Prinzip brauchst du nur den Kernel der Alten Firmware (Du flashst einfach die Rom, wobei du alles außer ''Exclude Kernel'' am Rand antickst), das Roottool und die aktuelle Rom, von der du dann auch nur den Kernel flashst.
Grüße

— geändert am 14.02.2014 15:44:55

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 29

14.02.2014 18:16:41 via Website

Kai R.

Im Prinzip brauchst du nur den Kernel der Alten Firmware (Du flashst einfach die Rom, wobei du alles außer ''Exclude Kernel'' am Rand antickst), das Roottool und die aktuelle Rom, von der du dann auch nur den Kernel flashst.
Grüße

Und genau das versuche ich schon erfolglos. Flashe ich den Kernel von .67, bleibts beim Loop mit Sony-Logo. Flashe ich .423, den ersten Kernel, denn ich überhaupt mal zum Rooten (damals erfolgreich) genutzt habe, ist es exakt dasselbe Bild.

Ich bekomme das XZ partout nicht per Downgrade runter. :angry:
  • Forum-Beiträge: 835

14.02.2014 20:10:17 via App

dann musst du warten oder den Bootloader entsperren. allerdings empfehle ich letzteres ausdrücklich nicht, da du ohne TA backup keine Chancen hast, dein Handy wieder wie neu zu verkaufen.
falls du ein downgrade schaffst, gibt es eine Möglichkeit, die ich selbst auch genutzt habe.
allerdings kümmere ich mich jetzt nicht darum... Schreibe nochmal wenn du das downgrade hinbekommen hast.
Grüße

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 29

17.02.2014 12:14:27 via Website

Okay, ich verliere also Bravia Engine für die Fotos (deren Qualität im XZ eh nicht berauschend ist und durch Google+ sowieso noch veredelt werden) und für TrackID brauch ich die DRM-Keys?

Da ich das Teil eh nicht verkaufen werde und ich höchstens Schnappschüsse mit dem Phone mache, wären es Dinge die ich vernachlässigen kann. TrackID-Alternative wäre SoundHound, sofern ich es überhaupt benutzen würde.

Dann werde ich mich wohl mal daran begeben den Bootloder zu entsperren, da ich das Downgrade überhaupt nicht hinkriege.
  • Forum-Beiträge: 835

17.02.2014 13:05:41 via App

du bräuchtest halt auch im garantiefall einen geschlossenen Bootloader. ich meine wenn das display innen nass ist, prüfen sie nicht die Software, aber wenn der Prozessor abschmiert oder so....

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 1

23.05.2014 00:28:40 via Website

Hallo zusammen.
Ich versuche nun seit 3 Tagen das Handy meiner Tochter zu reparieren. Ein Sony Xperia SP. Es wurde ein Update (leider keine genauen angaben) gemacht und seitdem geht nicht mehr viel. Wenn ich es einschalten will, blinkt nur die rote LED immer 2 mal. Wenn es das Ladegerät einstöpsel dann leuchtet es dauerhaft rot. Ab und zu springt es auf Grün um dann versucht es wohl zu starten (ist aber willkürlich) und zeigt nur das Sony Logo. Das kann ich aber nicht selber herbeirufen sondern das passiert irgendwann wenn es längere Zeit am Ladegerät hängt. Update Service und PC Companion scheitern beide da, wenn der PC sich mal connected bzw. das Sp dann eben nur kurz und bricht dann wieder ab. So konnte ich auch mit dem Flashtool nicht weiterkommen. Hardreset (On und Lauter) klappt auch nach 4 min gedrückt halten nicht. Nun habe ich gerade nochmal probiert es zu flashen und wieder hat er abgebrochen nach wenigen Fortschritten. Habe es dann wieder dran gelassen am PC und auf einmal kam im Display eine Schild (Ausrufezeichen) und ein Schraubenschlüssel und es fing ein Balken an durch zu laufen. Brach dann aber wieder kurze Zeit später ab. Was stimmt bloß nicht mit dem SP? Jemand ne Idee wie ich es wieder zum laufen bekomme?

  • Forum-Beiträge: 835

23.05.2014 18:42:33 via App

habt ihr irgendwelche Modifikationen vorgenommen?
Falls nicht, versuche es mal offiziell über Sony Update Service.
Falls auch das nicht geht, Flashe es mal via Flashtool, aber nimm alle Partitionen außer Kernel raus.
Also "Exclude X" und Y außer Kernel.
fan starte es bei uns siehe, ob ein Kernel Logo "Sony" auftaucht
Grüße

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X

  • Forum-Beiträge: 566

10.06.2014 23:54:21 via Website

Dennis Scholz

Hallo zusammen.
Ich versuche nun seit 3 Tagen das Handy meiner Tochter zu reparieren. Ein Sony Xperia SP. Es wurde ein Update (leider keine genauen angaben) gemacht und seitdem geht nicht mehr viel. Wenn ich es einschalten will, blinkt nur die rote LED immer 2 mal. Wenn es das Ladegerät einstöpsel dann leuchtet es dauerhaft rot. Ab und zu springt es auf Grün um dann versucht es wohl zu starten (ist aber willkürlich) und zeigt nur das Sony Logo. Das kann ich aber nicht selber herbeirufen sondern das passiert irgendwann wenn es längere Zeit am Ladegerät hängt. Update Service und PC Companion scheitern beide da, wenn der PC sich mal connected bzw. das Sp dann eben nur kurz und bricht dann wieder ab. So konnte ich auch mit dem Flashtool nicht weiterkommen. Hardreset (On und Lauter) klappt auch nach 4 min gedrückt halten nicht. Nun habe ich gerade nochmal probiert es zu flashen und wieder hat er abgebrochen nach wenigen Fortschritten. Habe es dann wieder dran gelassen am PC und auf einmal kam im Display eine Schild (Ausrufezeichen) und ein Schraubenschlüssel und es fing ein Balken an durch zu laufen. Brach dann aber wieder kurze Zeit später ab. Was stimmt bloß nicht mit dem SP? Jemand ne Idee wie ich es wieder zum laufen bekomme?

Das Handy ist tiefenentladen. Das passiert wenn der Akku so leer wird, das es nicht mal mehr noch starten kann. Einfach 2 stunden mal komplett unberührt laden lassen und alles ist wieder OK. Zum Thema Update, verweise ich dich mal auf meine Signatur, das sollte dir helfen

https://www.milianoids.com
Milianoids - Die Webseite für Sony Xperia Anleitungen, Firmware & Whitepaper !

Bei uns findet ihr alle wichtigen Anleitungen zu Sony Xperia so wie immer aktuelle Firmware und Whitepaper zu allen Modellen die in Europa verfügbar sind​

  • Forum-Beiträge: 566

10.06.2014 23:54:41 via Website

Dennis Scholz

Hallo zusammen.
Ich versuche nun seit 3 Tagen das Handy meiner Tochter zu reparieren. Ein Sony Xperia SP. Es wurde ein Update (leider keine genauen angaben) gemacht und seitdem geht nicht mehr viel. Wenn ich es einschalten will, blinkt nur die rote LED immer 2 mal. Wenn es das Ladegerät einstöpsel dann leuchtet es dauerhaft rot. Ab und zu springt es auf Grün um dann versucht es wohl zu starten (ist aber willkürlich) und zeigt nur das Sony Logo. Das kann ich aber nicht selber herbeirufen sondern das passiert irgendwann wenn es längere Zeit am Ladegerät hängt. Update Service und PC Companion scheitern beide da, wenn der PC sich mal connected bzw. das Sp dann eben nur kurz und bricht dann wieder ab. So konnte ich auch mit dem Flashtool nicht weiterkommen. Hardreset (On und Lauter) klappt auch nach 4 min gedrückt halten nicht. Nun habe ich gerade nochmal probiert es zu flashen und wieder hat er abgebrochen nach wenigen Fortschritten. Habe es dann wieder dran gelassen am PC und auf einmal kam im Display eine Schild (Ausrufezeichen) und ein Schraubenschlüssel und es fing ein Balken an durch zu laufen. Brach dann aber wieder kurze Zeit später ab. Was stimmt bloß nicht mit dem SP? Jemand ne Idee wie ich es wieder zum laufen bekomme?

Das Handy ist tiefenentladen. Das passiert wenn der Akku so leer wird, das es nicht mal mehr noch starten kann. Einfach 2 stunden mal komplett unberührt laden lassen und alles ist wieder OK. Zum Thema Update, verweise ich dich mal auf meine Signatur, das sollte dir helfen

https://www.milianoids.com
Milianoids - Die Webseite für Sony Xperia Anleitungen, Firmware & Whitepaper !

Bei uns findet ihr alle wichtigen Anleitungen zu Sony Xperia so wie immer aktuelle Firmware und Whitepaper zu allen Modellen die in Europa verfügbar sind​

  • Forum-Beiträge: 566

10.06.2014 23:55:07 via Website

Dennis Scholz

Hallo zusammen.
Ich versuche nun seit 3 Tagen das Handy meiner Tochter zu reparieren. Ein Sony Xperia SP. Es wurde ein Update (leider keine genauen angaben) gemacht und seitdem geht nicht mehr viel. Wenn ich es einschalten will, blinkt nur die rote LED immer 2 mal. Wenn es das Ladegerät einstöpsel dann leuchtet es dauerhaft rot. Ab und zu springt es auf Grün um dann versucht es wohl zu starten (ist aber willkürlich) und zeigt nur das Sony Logo. Das kann ich aber nicht selber herbeirufen sondern das passiert irgendwann wenn es längere Zeit am Ladegerät hängt. Update Service und PC Companion scheitern beide da, wenn der PC sich mal connected bzw. das Sp dann eben nur kurz und bricht dann wieder ab. So konnte ich auch mit dem Flashtool nicht weiterkommen. Hardreset (On und Lauter) klappt auch nach 4 min gedrückt halten nicht. Nun habe ich gerade nochmal probiert es zu flashen und wieder hat er abgebrochen nach wenigen Fortschritten. Habe es dann wieder dran gelassen am PC und auf einmal kam im Display eine Schild (Ausrufezeichen) und ein Schraubenschlüssel und es fing ein Balken an durch zu laufen. Brach dann aber wieder kurze Zeit später ab. Was stimmt bloß nicht mit dem SP? Jemand ne Idee wie ich es wieder zum laufen bekomme?

Das Handy ist tiefenentladen. Das passiert wenn der Akku so leer wird, das es nicht mal mehr noch starten kann. Schädlich für Akku und Gerät, sollte man also tunlichst vermeiden. Einfach 2 stunden mal komplett unberührt laden lassen und alles ist wieder OK. Zum Thema Update, verweise ich dich mal auf meine Signatur, das sollte dir helfen

https://www.milianoids.com
Milianoids - Die Webseite für Sony Xperia Anleitungen, Firmware & Whitepaper !

Bei uns findet ihr alle wichtigen Anleitungen zu Sony Xperia so wie immer aktuelle Firmware und Whitepaper zu allen Modellen die in Europa verfügbar sind​

  • Forum-Beiträge: 566

10.06.2014 23:55:09 via Website

Dennis Scholz

Hallo zusammen.
Ich versuche nun seit 3 Tagen das Handy meiner Tochter zu reparieren. Ein Sony Xperia SP. Es wurde ein Update (leider keine genauen angaben) gemacht und seitdem geht nicht mehr viel. Wenn ich es einschalten will, blinkt nur die rote LED immer 2 mal. Wenn es das Ladegerät einstöpsel dann leuchtet es dauerhaft rot. Ab und zu springt es auf Grün um dann versucht es wohl zu starten (ist aber willkürlich) und zeigt nur das Sony Logo. Das kann ich aber nicht selber herbeirufen sondern das passiert irgendwann wenn es längere Zeit am Ladegerät hängt. Update Service und PC Companion scheitern beide da, wenn der PC sich mal connected bzw. das Sp dann eben nur kurz und bricht dann wieder ab. So konnte ich auch mit dem Flashtool nicht weiterkommen. Hardreset (On und Lauter) klappt auch nach 4 min gedrückt halten nicht. Nun habe ich gerade nochmal probiert es zu flashen und wieder hat er abgebrochen nach wenigen Fortschritten. Habe es dann wieder dran gelassen am PC und auf einmal kam im Display eine Schild (Ausrufezeichen) und ein Schraubenschlüssel und es fing ein Balken an durch zu laufen. Brach dann aber wieder kurze Zeit später ab. Was stimmt bloß nicht mit dem SP? Jemand ne Idee wie ich es wieder zum laufen bekomme?

Das Handy ist tiefenentladen. Das passiert wenn der Akku so leer wird, das es nicht mal mehr noch starten kann. Schädlich für Akku und Gerät, sollte man also tunlichst vermeiden. Einfach 2 stunden mal komplett unberührt laden lassen und alles ist wieder OK. Zum Thema Update, verweise ich dich mal auf meine Signatur, das sollte dir helfen

https://www.milianoids.com
Milianoids - Die Webseite für Sony Xperia Anleitungen, Firmware & Whitepaper !

Bei uns findet ihr alle wichtigen Anleitungen zu Sony Xperia so wie immer aktuelle Firmware und Whitepaper zu allen Modellen die in Europa verfügbar sind​

  • Forum-Beiträge: 3

18.07.2014 05:55:58 via Website

Hallo Kai,

habe o.g. Anleitung befolgt, um einen bootloop auf der gerooteten StockROM, sowie auch auf CM11 wieder zu entfernen. Leider ohne Erfolg - das device hängt die meiste Zeit trotzdem noch beim Sony Logo oder ich kann zwar meine PIN eingeben, aber es schmiert wieder ab.

das Flashtool brauchte mehrere Anläufe, um ohne Fehlermeldung die StockROM zu flashen. Verwendet habe ich die C503_12.0.A.2.205_CE, denn die in Klammern stehende ftf hab ich nicht gefunden und die deutschsprachige Version mit der richtigen Nummer ist off.

Was kann ich noch tun, damit mein Gerät wieder sauber läuft? (SUS will nicht reparieren, weil es die abgeänderte Software erkennt).

viele Grüße voller Hoffnung,
die mogo12

  • Forum-Beiträge: 3

18.07.2014 09:27:57 via Website

edit: mglw. ist der bootloader noch unlocked - ich prüf das heut nachmittag und versuche dann nochmal das firmware update über SUS.
melde mich wieder,

die mogo12, die selbst schon fast im bootloop hängt ;)

  • Forum-Beiträge: 3

19.07.2014 10:39:32 via Website

liebe community - ich stecke absolut fest und brauche dringend eure Hilfe!!!!

nach relativ erfolgreichem flash der stockrom im oberen post, war der bootloob nur noch punktuell vorhanden - der versuch meinen bootloader wieder zu sperren (mit backup TA) hat das device aber komplett in schlaf versetzt -rootrechte waren ja weg und im log stand, dass adb-treiber gelöscht wurden.
device vibriert länger beim starten, zeigt sony-logo und wird dann schwarz.

ist hier noch was zu retten???

bitte um anleitung!!!

viele grüße!

  • Forum-Beiträge: 2

20.07.2014 17:18:24 via App

Hallo, kann mir jemand sagen ob es schon ein Update auf 4.0 ICE Creme für das xperia Go gibt? Wollte mir eines in der Bucht kaufen. Vg.

  • Forum-Beiträge: 835

01.08.2014 20:50:47 via App

mogo12

liebe community - ich stecke absolut fest und brauche dringend eure Hilfe!!!!

nach relativ erfolgreichem flash der stockrom im oberen post, war der bootloob nur noch punktuell vorhanden - der versuch meinen bootloader wieder zu sperren (mit backup TA) hat das device aber komplett in schlaf versetzt -rootrechte waren ja weg und im log stand, dass adb-treiber gelöscht wurden.
device vibriert länger beim starten, zeigt sony-logo und wird dann schwarz.

ist hier noch was zu retten???
bitte um anleitung!!!

viele grüße!

C6503 Xperia ZL?
Seltsamerweise ist mir exakt dasselbe passiert... Ein paar Reboots hier und da, dann war Sense. Ich habe es mitunter noch mit Ladekabel zum laufen bekommen, aber es war eine Qual die Stock Rom zu flashen, USB-debugging zu aktivieren und TA hat trotzdem nicht funktioniert.
Dann kam kurz das Sony Logo, dann Schluss. Aus. Ende.
Lustigerweise passierte das genau drei Tage vor Akazie der Gewährleistung, unlustigerweise ist es halt noch entsperrt, es wird wohl nicht einfach repariert m habe es trotzdem mal eingeschickt.

Falls dein Bootloader entsperrt ist, wird SUS nicht funktionieren...
Ich fürchte, dass dieser Fehler nicht auf die Software zurück zu führen ist.
Ich schreibe hired, sobald ich etwas höre.
Grüße

— geändert am 01.08.2014 20:52:06

Sony Ericsson Xperia X10 - nach langem Diesnt in Rente; verschenkt
Sony Xperia ZL (Odin) - gebrickt; repariert, meiner Mutter angedreht
Motorola Moto G 4G - endlich entsperrt & gerootet - verscherbelt
Nexus 4 - MultiROM mit SailfishOS, FirefoxOS & Ubuntu Touch - auf Arbeit ins Klo gefallen
Sony Xperia Z1 Compact - Cynogenmod 12.1
Innos D6000 - nicht rootbar
Momentan: Xiaomi Redmi 4X