Einmal GPS angehabt und Akkuverbrauch im Standby steigt - obwohl GPS wieder aus ist.

  • Antworten:11
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 9

14.11.2013 23:33:20 via Website

Hallo zusammen,

ich unterstelle mal, dass es ein allgemeines Problem ist oder zumindest die Analyse geräteunabhängig begonnen werden kann.

Ich habe ein S4 mini und folgende Auffälligkeit im Verlauf des Akkuverbrauchs:

Wann immer ich eine Anwendung laufen hatte, die GPS benötigt steigt der Akkuverbrauch NACH Ausschalten von GPS im anschließenden Standby-Modus des Gerätes stark an. Auch alle Apps sind lt. App-Manager beendet.

Unter starkem Anstieg verstehe ich z.B. Folgendes:
Flugzeugmodus über Nacht Akkuverbrauch „normal“ ca. 5%.
Hatte ich zuvor mal GPS an gehabt, steigt der Akkuverbrauch im Flugmodus während der Nacht bei sonst gleichen Einstellungen auf ca. 20%.
Starte ich das Handy neu, aktiviere KEIN GPS, ist wieder alles gut und ich habe wieder einen geringen Akkuverbrauch.


Wie kann ich analysieren, an welcher Stelle die zusätzlichen Akkukapazitäten abgezogen werden?

Oder besser noch: Kennt einer das Problem und auch dessen Lösung?

Falls die Frage kommt, ob ich mir sicher bin GPS auch wirklich ausgemacht zu haben: Ja bin ich. Sowohl die Schnelleinstellungstaste im Benachrichtigungsfeld ist inaktiv als auch der Schalter unter Standortdienste/Zugriff auf meinen Standort ist „Aus“. Und ja, ich habe auch schon beide Varianten zum Deaktivieren des GPS‘ versucht (Schelleinstellungstaste und Menüeinstieg), in beiden Fällen steigt der Akkuverbrauch nach einmaliger GPS-Nutzung im anschließenden Standby-Modus an.

Vielen Dank.
  • Forum-Beiträge: 33.139

15.11.2013 06:36:10 via App

Hi,

Also eigentlich braucht man GPS nicht dauernd ein- und auszuschalten. Die GPS Bereitschaft verbraucht Null Strom. Lediglich die GPS *Aktivität* braucht natürlich Strom.

Also das ein- und ausschalten ist eigentlich unnötig, eher kontraproduktiv.

Hast Du schon mal geprüft, wie der Verbrauch ist, wenn Du das Gerät neu startet, GPS Bereitschaft eingeschaltet ist, aber keine App gestartet wird, die GPS aktiv nutzt?

Herzliche Grüße

Carsten

— geändert am 15.11.2013 06:36:39

Ich komm' mir langsam vor wie jemand, der ich bin // #cäthe

  • Forum-Beiträge: 9

16.11.2013 11:19:44 via Website

Hallo Carsten,

Danke für deine Anregung. Leider bleibt der Akkuverbrauch konstant gut oder schlecht, egal welche Variante des Einschaltens ich wähle. Einmal dann eine App mit GPS gestartet - irgendwann will ich ja mal auch GPS tatsächlich nutzen, schon schnellt der anschließende Standby-Verbrauch nach Abschalten der App in die Höhe.
  • Forum-Beiträge: 9

16.11.2013 11:21:33 via Website

@all:

Eine weite Feststellung konnte ich jetzt machen:
Handy auf 100% geladen.
Ein wenig via WLAN zu Hause im Internet gesurft (alles ohne GPS).
Bei 92% und eingeschaltetem WLAN in für die den Flugmodus gewechselt (WLAN ist mit ausgegangen so wie es sein soll).
Heute früh: rd. -20% über Nacht Akkuverbrauch...

Ich bleibe bei der Behauptung alle mir ersichtlichen Prozesse beendet zu haben. Keine Standortbestimmungen oder auto. Sync-Funktionen, auto. Updates etc. im Hintergrund. Ich habe keine Flat und mache mir daher einen "Sport" daraus, möglichst alle Funktionen dieser Art zu deaktivieren. Lt. Task-Manager ("Aktive App-Manager") ist angeblich alles aus was die Apps angeht. Auch den in diesem Bereich aufzurufenden "RAM"-Speicher habe ich geleert: Es werden dann immer erst mal ca. 50 Prozesse beendet und zumindest nicht sofort wieder alle erneut gestartet. Das brachte gelegentlich auch eine Verbesserung sprich Abflachung der Akkuverbrauchskurve. Dies hatte ich auch für heute Nacht so gemacht (nur gesurft, alle Apps, RAM gelöscht und Flugmodus an) und -siehe oben-, diesmal hat es nichts gebracht. Der Effekt ist also nicht gezielt reproduzierbar via Löschung RAM.

Allein das ausschalten und erneute Starten des Handys brachte wieder den gewünschten Effekt. Der Kurvenverlauf beim Akku ist sofort wieder flach.

Wer saugt am Akku? Wie kann ich "ihn" enttarnen? Und wie kann ich "ihn" steuern (abschalten) ohne das Gerät neu zu starten? Oder besser noch: Ja nach dem, ob es eine systemrelevante Komponente ist: Kann ich "sie" löschen?

Einmal mehr Danke im Voraus und ein Schönes WE.
  • Forum-Beiträge: 33.139

16.11.2013 11:23:52 via App

Wie, was heißt mal gut, mal schlecht?

Ist denn nun nach Neustart des Gerätes mit aktiviertem GPS, aber ohne Nutzung des GPS der Stromverbrauch okay oder nicht okay?

Herzliche Grüße
Carsten

Ich komm' mir langsam vor wie jemand, der ich bin // #cäthe

  • Forum-Beiträge: 33.139

16.11.2013 11:27:07 via App

Und höre mal auf, Anwendungen aus dem RAM zu löschen... Das bringt garantiert schon mal gar nichts in Bezug auf den Stromverbrauch, eher im Gegenteil.

Ich würde Dir raten, mal einen Werksreset zu machen und dann das Gerät einfach mal arbeiten zu lassen, ohne dauernd irgendwas zu killen, zu löschen oder sonstwie rumzubasteln...

Herzliche Grüße

Carsten

Ich komm' mir langsam vor wie jemand, der ich bin // #cäthe

  • Forum-Beiträge: 677

16.11.2013 17:45:34 via Website

Ich hatte auch Akkuverbrauchsprobleme wenn ich am GPS einstellungen geändert hab, nach nem neustart gings wieder. also schalts mal ab und starte das handy neu. danach nicht wieder rumstellen und beobachten

Sony Xperia Z3 Schwarz (Android 6.0.1 stock)
Sony Xperia Tablez Z LTE Schwarz (Vanir Android 6.0.1)

  • Forum-Beiträge: 9

16.11.2013 18:36:23 via Website

@kampfkeks:
Danke für die Nachricht.
Weißt du noch, bei welchem deiner Geräte du das Problem hattest? Würde evtl. helfen einzugrenzen: Androidproblem oder Touchwizproblem.

Wie bereits geschrieben, auch bei mir ist es so, dass wenn ich das Gerät neu starte erstmal alles wieder gut ist - bis nach der erstmaligen GPS-Nutzung.

Du schreibst du "hattest" das Problem. Hast du es im Grundsatz gelöst oder lebst du mit dem Workaround "Neustart"
  • Forum-Beiträge: 677

16.11.2013 18:39:56 via Website

hatte bisher 2 Androidgeräte, und jeweils das Problem.
Galaxy S2 und aktuell Sony Xperia Z. Habe allerdings beim Z das GPS immer an, und klar steigt der Akkuverbrauch etwas, wenn ne App jetzt signal sucht, die "google dienste" die dafür ja verantwortlich sind stehen bei mir auch auf Platz 2 hinterm Display der verbraucher. aber ich komme trotzdem 2 Tage mit einer Ladung aus. Aber sobald man was ändert fängt er an leerzusaugen als wenn sich was aufhängt im Android system, bis nach nem neustart, dann gehts

Sony Xperia Z3 Schwarz (Android 6.0.1 stock)
Sony Xperia Tablez Z LTE Schwarz (Vanir Android 6.0.1)

  • Forum-Beiträge: 9

17.11.2013 18:32:21 via Website

@ Carsten und kampfkeks:
Danke euch beiden, nachdem ich mit der Beschreibung von Carsten noch so meine Schwierigkeiten hatte, hab ich’s jetzt offenbar begriffen: GPS erlauben und Finger weg, Neustart und weiterhin Finger weg von der GPS-Erlaubnis. Apps nutzten und beenden und auch jetzt noch Finger weg von der GPS-Erlaubnis. Ja, jetzt bleibt auch bei mir der Akkuverbrauch nachvollziehbar in den Standby-Phasen.
  • Forum-Beiträge: 9

17.11.2013 18:33:34 via Website

So, damit haben wir das Thema offenbar soweit erst mal eingekreist und einen Workaround.

Das eigentliche Problem scheint aber ja nun zu sein, dass Geräteunabhängig und offenbar seit einigen Android-Versionen ein Bug existiert, wenn nicht noch jemand in der Lage ist aufzuzeigen wie ohne, dass ein Neustart vollzogen wird der zusätzliche Akkuverbrauch wieder „abgeschaltet“ wird, wenn man – warum auch immer – GPS-Erlaubnis mal entzogen hat. M. E. ist dies sonst eine Sache für Entwickler die sich mit dem inneren von Android besser auskennen.

Und noch was hab ich in diesem Zusammenhang auch festgestellt:
Schalte ich WLAN aus, steigt der Akkuverbrauch im Standby. Allerdings im Unterschied zum GPS-Thema sinkt der Akkuverbrauch wenn WLAN wieder aktiviert ist und das Gerät in Standby schaltet. Mobile Daten ist dabei auch aus (hab keine Flat) und sämtliche Google-Programme die sonst evtl. in Netz wollen meine ich ohnehin deaktiviert zu haben.

Für mich als Programmierer-Laien drängt sich hier die Vermutung auf, dass das Ausschalten bzw. das Entziehen der Nutzungsberechtigung von GPS und/oder WLAN aktiv kontrolliert wird und somit durch diese Kontrolle zusätzliche Prozesse und Aktivitäten ausgelöst werden die dann eben mehr Akku verbrauchen. Wäre jedenfalls eine Erklärung für das Paradoxum „mehr Akkuverbrauch“ durch „Ausschalten“.

Offenbar haben immerhin schon drei Androiduser ähnliche Erfahrungen auf verschiedenen Geräten und vermutlich auch verschiedenen Android-Versionen gemacht. Wenn da also was dran ist – und es erst mal unter Android auch so bleibt: Dann wäre das für mich ein zusätzlicher Punkt unter Tipps zum Akkusparen wie sie gerade von Nico wieder mal zusammengetragen worden sind.

Also, m.E. bleiben nun folgende Fragen:
Kann man den zusätzlichen Akkuverbrauch durch richtige Bedienung von Android verhindern?
Ist es ein Bug? Gibt es ihn unter 4.3 und 4.4 noch? Mein S4 mini läuft noch mit 4.2.2
Sollte man die Akkuspartipps erweitern?