Sony Xperia Z — Verbindung mit dem Auto via Bluetooth - Probleme

  • Antworten:41
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 978

15.04.2013 22:01:06 via Website

Claus Köppel
das gleiche Problem habe ich auch. Als ich es das erste Mal gekoppelt hatte, hat es scheinbar funktioniert. Dann sind diese Unterbrechungen aufgetreten. Den Stamnia Modus hatte ich auch schon mal an. Da ist das Bluetooth im Auto abgestürzt und es ging gar nichts mehr. Kann es am Auto liegen? Ich habe einen Audi Q5.
Welches BT hast Du? Es gibt unterschiedliche von Audi. Aber aller meiner Ansicht nach sehr empfindlich mit Gerätekompatiebilität. Audi scheint nur noch für Apple direkt zu implementieren (früher Nokia). Meines wissens sind die VAG Implementierungen überwiegend von Nokia (lasse mich aber gerne anders belehren).

Corinna C.
Wäre natürlich blöd wenn es an Audi liegt... -.-
Denn ich habe ein Audi TT. Dürfte aber ja nicht sein...
Es kann nicht sein was nicht sein darf?!

Also generell scheint Audi Probleme mit der Mobielfunkkopplung zu haben. Mein A4 allroad mit MMI (ohne Plus) und BT-FS, hat sich immer wieder nicht mit dem vorherigen Nokia N8 Verbunden, bzw. ist bei Gesprächsstart abgestürzt. Ähnliches Phänomen habe ich noch mit einem Google Nexus S und CyanogenMod 7.1 gehabt. Ich habe es allerdings nicht mit dem Xperia Mini Pro meiner Frau (weder mit der 2.6-er die drauf war noch nach dem Update auf die 4-er). Mein XZ läuft aber soweit ich das beurteilen kann einwandfrei. Sowohl die Steuerung als auch der Abgleich des Telefonbuchs.

Generell ist das mit der BT-Kompatibilität so eine Sache (weiß ich, seit dem wir dort auch schon für eine SPP only einige Entwickler-Monate verbraten haben. Also ist weder ein reines Problem eines Auto- oder Handylieferanten, sondern eine Frage der Gewissenhaftigkeit und dem Wille wirklich jedes noch so exotische Telefon zu testen (mit allen lieferbaren SW Varianten). Also schier eine Exponentielle Aufgabe. Diese wird in der Regel von einigen BT-Modul Lieferanten übernommen, die dieses mehr oder weniger in jedes Auto liefern.

Was könnt Ihr tun. Zuerst geht Ihr zum Audi-Händler Eures Vertrauens. Dort verlangt Ihr, dass dieser in der Fehlerdatenbank nach Euren Fehler sucht. Findet er was vergleichbares habt Ihr Glück, dann wird er ein SW update des BT Moduls oder des MMIs durchführen. Wenn Ihr noch mehr Glück habt klappt es anschließend. Bei mir ist nach dem zweiten Update, dass Problem wenigstens nicht mehr so stark gewesen. Übrigens hatte der Freundliche Werkstattsprezialist einen guten Tip, stelle das Handy auf GSM (2G), dann soll es besser gehen - schwup er hatte Recht - es war besser.

Der zweite Tip ist, Handy Trennen und Verbindung aus liste löschen. Erneutes Koppeln der beiden. Den NFC Tag ins Auto legen (ich meine einer der beiden ist schon für die Auto Kopplung vorgesehen). Dort dann mal das Handy auf GSM(2G) only umstellen lassen. BT-Verbindung einschalten und mal in den CAR Modus (Sony Auto). Bitte kurze Rückmeldung ob Ihr weiter gekommen seid.
Viel Glück :-)
  • Forum-Beiträge: 9

16.04.2013 09:41:47 via Website

Hallo,

ich habe keinen Audi, sondern einen MX5 und das gleiche Problem. Vorher hatte ich auch ein Desire HD und nie Probleme.Jetzt stellt er die Verbindung her und dann ist sie wieder weg.
Hat sich inzwischen was getan?

Gruß,
Petro

— geändert am 16.04.2013 09:42:17

  • Forum-Beiträge: 11

16.04.2013 10:17:34 via Website

Ich habe es jetzt ausprobiert.
Wenn ich das Gerät kopple, dann kommt die Abfrage, ob AUDI UHV 5252 auf die Kontakte zugreifen darf. Wenn ich hier nicht OK bestätige, sondern den Zugriff mit "Abbrechen" nicht zulasse, dann geht die Verbindung und das Telefonieren problemlos. Man hat halt die Kontakte dann nicht im Zugriff über das Telefonbuch im Auto.

Man bräuchte also ein Tool, das die Schrägstriche aus den Kontakten entfernt.

Gruß,
Claus
  • Forum-Beiträge: 978

16.04.2013 22:40:37 via Website

Claus Köppel
Ich habe es jetzt ausprobiert.
Wenn ich das Gerät kopple, dann kommt die Abfrage, ob AUDI UHV 5252 auf die Kontakte zugreifen darf. Wenn ich hier nicht OK bestätige, sondern den Zugriff mit "Abbrechen" nicht zulasse, dann geht die Verbindung und das Telefonieren problemlos. Man hat halt die Kontakte dann nicht im Zugriff über das Telefonbuch im Auto.
OK, dass kann auch mit ein Grund sein, dass nicht erlaubte Zeichen im Telefonbuch (in der Telefonnummer sind). Bei mir akzeptiert das Telefon + am Anfang (für +49 oder anderen Ländercode) Bindestrich und Leerstelle/Blank. Alle anderen Zeichen habe ich sowieso gemieden, da einige Programme damit Probleme hatten (auch einige Telefone). Nokia hat nicht mal Bindestrich und Leerstelle/Blank in Telefonnummern ermöglicht, bei importierten aber immerhin dann gewählt. Klammer und Schrägstrich (shift+F7) sind aber immer zu vermeiden.

Claus Köppel
Man bräuchte also ein Tool, das die Schrägstriche aus den Kontakten entfernt.
Es gibt eine einfache Lösung die mir einfällt. Exportiere das Telefonbuch z.B. im vCard Format. Diese Textdatei editierst Du dann, automatisch z.B. auf der Kommandozeile mit der Bash/sed/perl oder aber mit einem Leistungsfähigen Editor, der umfangreiche suchen/ersetzten regeln versteht (z.B. Linux Syntax):
de.wikipedia.org/wiki/Sed_(Unix)
Anschließend (am besten nach einer Sicherung) wieder importieren. Vorher das alte Telfonbuch löschen - um Dupletten zu vermeiden.

Allgemeine Info zu Telefonnummern Formaten:
www.barrierefreie-webloesungen.de/blog/misc/120413_telefon.php

Petrocelli
ich habe keinen Audi, sondern einen MX5 und das gleiche Problem. Vorher hatte ich auch ein Desire HD und nie Probleme.Jetzt stellt er die Verbindung her und dann ist sie wieder weg.
Ich habe beim XZ beobachtet, dass es keine zyklischen statusupdates sendet (z.B. die Empfangsstärke), welches z.B. mein Vorgänger Nokia N8 und einige andere tun. Dieses scheinen einige als nicht mehr verbunden zu interpretieren, eine erneute Verbindung scheitert dann aber unter umständen an der fehlenden Sichtbarkeit. Stelle doch mal am Auto vorübergehend die Sichtbarkeit/Suche des Bluetooth Empfängers auf "immer sichtbar" bzw. "immer koppelbar" (bei mir steht sie z.B. auf "Auto" => wie Automatisch) was gut funktioniert. Aber Achtung, damit kann sich dann aber unter Umständen jemand anderes mit dem Bluetooth Freisprechanlage koppeln!
  • Forum-Beiträge: 11

17.04.2013 07:58:37 via Website

Es gibt eine einfache Lösung die mir einfällt. Exportiere das Telefonbuch z.B. im vCard Format. Diese Textdatei editierst Du dann, automatisch z.B. auf der Kommandozeile mit der Bash/sed/perl oder aber mit einem Leistungsfähigen Editor, der umfangreiche suchen/ersetzten regeln versteht (z.B. Linux Syntax):
Beim Export der Outlookdaten mit dem SonyPCCompanion wird eine vcf erzeugt und auf das Telefon kopiert. Ich habe diese Datei geöffnet. Dort sind alle Kontakte korrekt im Format +49 (XXX) XXXXXXX eingetragen. Der Schrägstrich wird offensichtlich erst vom Betriebssystem erzeugt.
Gruß
Claus
  • Forum-Beiträge: 2.159

17.04.2013 08:49:55 via Website

Der Schrägstrich wird offensichtlich erst vom Betriebssystem erzeugt.

heißt also ohne Rooten bekommt man die Striche wohl nicht weg, wenn´s direkt vom System erzeugt wird :/

Schenkt Ihnen nichts, aber nehmt Ihnen alles!

  • Forum-Beiträge: 11

19.04.2013 17:36:41 via Website

Hallo,
Vielleicht gehts ja damit:

[app]play.google.com/store/apps/details?id=com.android_rsap.irmc&hl=de[/app]

Hat das schon jemand versucht?

Gruß
Claus
  • Forum-Beiträge: 978

19.04.2013 19:13:22 via Website

Claus Köppel
Beim Export der Outlookdaten mit dem SonyPCCompanion wird eine vcf erzeugt und auf das Telefon kopiert. Ich habe diese Datei geöffnet. Dort sind alle Kontakte korrekt im Format +49 (XXX) XXXXXXX eingetragen. Der Schrägstrich wird offensichtlich erst vom Betriebssystem erzeugt.
Ist eigentlich komisch, dass hier das Windows Format genommen wird, welches eigentlich nicht dem Standard (hier gilt normal die RFC) genommen wird. Siehe auch Wikipedia:
de.wikipedia.org/wiki/Rufnummer#Internationale_Rufnummern
Eigentlich sollten die Nummern im RFC 3966 (z.B. +49-30-1234567) gespeichert werden. Alternativ können auch die "-" durch Leerstellen ersetzt werden (E.123). Was eigentlich immer Ärger macht sind Klammern und "/" oder gar andere Zeichen. Deshalb speichere ich alle nummern im RFC nahen E.123 ab (also mit Leerzeichen getrennt).

Kannst Du mal Versuchsweise evtl. eine gekürzte Liste nach dem E.123 anstelle des Proprietären MS Formats generieren und ersatzweise ins Handy speichern und es dann noch mal versuchen?
  • Forum-Beiträge: 11

20.04.2013 09:15:10 via Website

Ich habe jetzt mal die Telefonnummern geändert und alle Klammern aus der .vcf rausgelöscht. Somit gibt es nur noch Nummern im Format +49 30 1234567. Nach dem Import der Datei ins Handy sehen die Nummern aber genauso aus wie vorher: +49 30/1234567
In einem weiteren Versuch habe ich alle Zeichen aus den Nummern entfernt. So daß nur noch das Format +49301234567 übrig war. Der Erfolg war der gleiche.
Interessanterweise werden aber nur die Festnetznummern mit einem / versehen. Die Mobilfunknummern nicht.


Gruß
Claus
  • Forum-Beiträge: 978

20.04.2013 10:19:08 via Website

Hi Claus Köppel,

sieht so aus, als wenn (Sony) Android wieder versucht ne blöde Automatik zu implementieren. Aber warum kommen bei mir die Rufnummern an meinem Audi MMI ohne "/" und "(" bzw. ")" an?
  • Forum-Beiträge: 978

22.04.2013 20:40:55 via Website

Hallo Claus,

hat etwas länger gedauert, aber war am Wochenende ohne Auto unterwegs.

Also auch bei mir versucht Android Telefonnummern umzuinterpretieren (anzeige ). Im MMI wird es dann bei mir aber +4912345678 angezeigt. Also bis auf das + am Anfang nur Zahlen. Aber unbedingt beim Hersteller Motzten. Die Hersteller sind nur dann bereit etwas nachträglich zu ändern, wenn der Druck groß genug ist.

Nachtrag: Wenn ich sie z.B. auf meine SD-Karte speichere sind alle Telefonnummern ebenfalls ohne Zeichen

— geändert am 22.04.2013 20:52:28

  • Forum-Beiträge: 16

29.07.2013 13:10:26 via Website

Aus dem Grund habe ich aufgehört mit Android. Man kann sich auf die Bluetooth-Anbindung nicht verlassen. Und gerade im Auto ist es wichtig, dass man ablenkungsfrei telefonieren kann. Nimmt man ein aktuelles iPhone, gibt es da null Probleme; somit muss ich mich nun abfinden mit dem etwas kleineren Display des iP5, aber das mache ich gerne, da das Gerät einfach top ist und Bluetooth immer - ohne Ausnahme - funktioniert!

— geändert am 29.07.2013 13:14:02

  • Forum-Beiträge: 16

29.07.2013 13:23:41 via Website

Claus Köppel
Mit der aktuellen Version 4.2.2 ist das Problem (bei mir) behoben.



Schön für Dich! Aber spätestens dann, wenn ein neues Update angeboten wird, muss man wieder bangen....
Und das ist es mir nicht wert, bzw. den Stress kann man sich sparen ;-)
Ich finde Android ein tolles Betriebssystem, mit viele Möglichkeiten, die Bastelei mit Custom-ROMs ebenfalls ein tolle Sache. Ich habe ALLES ausprobiert, aber Bluetooth ist ne Katastrophe, die ich mir leider nicht gut erklären kann. Jetzt lese ich, dass sogar mit den neuesten Android-Handys Bluetooth Probleme existieren. Tja....
  • Forum-Beiträge: 1

31.07.2013 21:08:26 via Website

Nabend,

ich hatte das gleiche Problem mit meinem Octavia 2 RS ! Nach dem Koppeln und der Freigabe der Kontakte wurde das Handy entkoppelt !!!
Habe dann zisch mal, das Spiel von vorne begonnen und irgendwann dachte ich mir schei* drauf ! Vielleicht ne Woche später wollte ich das mal wieder probieren und auf einmal ging es ^^ -.- ...
Ich glaube ich habe irgendwo gelesen, dass das Auto eine Weile braucht, bis es alle Kontakte übernommen hat und es dabei zu Abbrüchen kommen kann.
Habe jedenfalls keine Änderungen am Handy vorgenommen, lediglich immer wieder versucht neu zu koppeln. Wenn ihr die Möglichkeit habt, ein anderes Handy zu koppeln, versucht das mal und dann wieder eures. Das Galaxy S3 meiner Frau hat auf Anhieb funktioniert. Vielleicht kalibriert sich dann das Bluetooth-Modul nochmal neu.

Könnte aber auch sein, das zwischendurch das Android bei mir kam. Nachvollziehen kann ich jetz leider nicht mehr, ob das zu diesem Zeitpunkt war!
  • Forum-Beiträge: 733

10.08.2013 00:41:38 via App

Nur als kleine Statusmeldung und Feedback, haben gestern unseren neuen Wagen (Peugeot 308 SW) bekommen und Anbindung via BT innerhalb einer Minute vorhanden und alle Kontakte und Anruflisten auf den Schirm. Total easy...
  • Forum-Beiträge: 1

02.11.2015 22:57:43 via Website

@Geronimo Das stimmt nicht ganz. Ich habe ein xz3 compact und große Probleme mit der Bluetooth Verbindung mit dem mmi in meinem a6 avant 3.0d quattro. Nach einem Besuch beim Händler hieß es dass die Updates vom mmi den handys hinterher hinken. Er meinte sogar dass es gerade mit dem iphone 6 viiiele Probleme gibt.

Bei mir brechen die Telefonate ab,mmi entkoppelt das z3 und schaltet die Sichtbarkeit selbst aus. Auch musik kann ich nur 10sek. Lang hören. Danach muss ich jedes mal das Bluetooth des mmi aus und nach 3 minütigem warten weil sich das mmi aufhängt wieder einschalten. Dann gehts wieder für weitere 10sek. Das nervt...ich gabe es mit dem sony m2 und dem motoG ausprobiert. Den moto findet er überhaupt nicht.

— geändert am 02.11.2015 22:59:49

  • Forum-Beiträge: 1

08.01.2017 18:45:02 via Website

Hy. Hatte das gleiche Problem. Hab nun vor ner Minute die App AUTO BUETOOTH CONECT runter geladen und es hat sofort funktioniert! Keine Ahnung ob es von dauer ist. Mfg Hannes

  • Forum-Beiträge: 1

27.03.2017 00:06:59 via Website

Hallo ich habe das Sony Xperia XA. Seit neuestem spinnt meine Bluetoothverbindung zwischen meinem Handy und meinem Auto. Ich fahre einen Ford Focus Mk3 bj 2013. Die ganze Zeit hat alles prima funktioniert und ich konnte die Freisprechfunktion via Bluetooth prima nutzen. Jetzt auf einmal funktioniert es nicht mehr. Ich kann mich erfolgreich verbinden, aber wenn ich telefonieren will geht der Anruf über das Handy und nicht über die Freisprechfunktion.