Google Galaxy Nexus — Problem bei E-Mail - Einrichtung - TLS erforderlich aber nicht von Server unterstützt

  • Antworten:17
  • OffenNicht stickyBentwortet
  • Forum-Beiträge: 8

28.05.2012 22:51:31 via Website

Moin zusammen,

ich habe ein etwas seltsames Problem mit der Standard-Mail App auf meinem Galaxy Nexus. Wenn ich mein E-Mail Konto einrichten möchte, klappt das bis zum Postausgangsserver. Klicke ich dann auf den finalen Weiter-Button bekomme ich die Fehlermeldung "TLS erforderlich aber nicht von Server unterstützt". Der Server funktioniert allerdings einwandfrei, das weiß ich aus Kontakt zum Server-Administrator. Ich habe von diesem Problem bis jetzt nur in Verbindung mit Web.de gelesen und meist lag es an falscher Konfiguration, diese ist allerdings 100%ig korrekt eingegeben.

Hat jemand eine Idee? Vielen Dank!
Jojo
  • Forum-Beiträge: 13.920

29.05.2012 18:40:29 via Website

Hallo

Was willst du einrichten ?? ( gmx,web.de,vr-web)

TLS hat mit Verschlüsselung zu tun. Ich denke, du hast nur eine Kleinigkeit verkehrt ausgewählt....
Oder Haken verkehrt ( Postausgang erfordert Autorisierung ) o.s.ä.

Grüße
Mia

Liebe Grüße
Mia

👑 👑 👑


Nexus <3


👑Screenshots richtig posten
👑Dirty Unicorns - Nexus 6P
👑Dirty Unicorns - Nexus 5

  • Forum-Beiträge: 8

29.05.2012 19:13:18 via Website

Moin,

danke für deine Antwort! Es handelt sich um eine E-Mail Adresse vom eigenen Webspace bei Uberspace. Mit einer E-Mail Adresse eines anderen Servers beim gleichen Hoster hatte ich keine Probleme bei der Einrichtung. Habe alles mehrfach nachgeprüft, alles korrekt eingestellt.

Grüße
Jojo
  • Forum-Beiträge: 509

02.06.2012 09:13:04 via App

probier mal ohne tls?
da ich selber 120 Server verwalte, kann ich hier nur vermuten, dass dieser hoster seine Server eben doch nicht ganz im griff hat...
  • Forum-Beiträge: 8

02.06.2012 10:01:25 via Website

Das kann ich 100%ig ausschließen, da unverschlüsselte Verbindungen erst gar nicht unterstützt werden. Wenn jemand Ahnung von der Materie hat, ist es das Team hinter Uberspace ;-)
  • Forum-Beiträge: 1.368

02.06.2012 15:46:40 via App

Jojo S.
Das kann ich 100%ig ausschließen, da unverschlüsselte Verbindungen erst gar nicht unterstützt werden.

Die Begründung passt nicht zur Aussage. Die Frage ist, WELCHE Verschlüsselung. Bist du ganz sicher, dass nicht SSL verlangt wird und auch dass du den korrekten Port verwendest?
  • Forum-Beiträge: 8

02.06.2012 15:53:29 via Website

nica
Die Begründung passt nicht zur Aussage.

Ohne TLS ist für mich = ohne Verschlüsselung.

nica
Die Frage ist, WELCHE Verschlüsselung. Bist du ganz sicher, dass nicht SSL verlangt wird und auch dass du den korrekten Port verwendest?

Ja, ich habe dies mehrfach kontrolliert und auch alle anderen möglichen Optionen ausprobiert.
Gelöschter Account
  • Forum-Beiträge: 5.215

02.06.2012 16:05:59 via Website

TLS = Weiterentwicklung von SSL seit der Version 3.0 (TLS = Transport Layer Security)

Problematisch dabei ist, dass einige Webserver und/oder Firewalls die terminieren, diese neuere Variante des SSL noch nicht unterstützen bzw. möglicherweise TLS dort nicht eingerichtet ist. Das kann einzelne Server oder im Fall einer davorliegenden Firewall ganze Dienste-Farmen betreffen.

Die Meldung " TLS erforderlich aber nicht von Server unterstützt" weist genau auf diesen Umstand hin. Die Tatsache, dass ein anderer Account, des selben Anbieters konfigurierbar ist deutet eher darauf hin, dass dort keine gemeinsame Firewall für die SSL-Terminierung zuständig ist, sondern die Server dieses Protokoll selber bereitstellen müssen.

Was in diesem Fall, bei dem betreffenden Server für den betreffenden Account wohl nicht der Fall zu sein scheint.

lg Voss

  • Forum-Beiträge: 8

02.06.2012 16:08:45 via Website

Jörg V.
...

Danke für deine ausführliche Antwort! :) Ich werde dem Hoster diese Beschreibung mal zukommen lassen.
  • Forum-Beiträge: 1.368

02.06.2012 17:30:14 via Website

Bei Uberspace muss man für SMTP den Port 587 mit STARTTLS-Verschlüsselung einstellen.
  • Forum-Beiträge: 8

03.06.2012 16:41:26 via Website

Ich weiß, mit der Einstellung habe ich es auch probiert.
  • Forum-Beiträge: 509

04.06.2012 20:12:17 via App

Jojo S.
Das kann ich 100%ig ausschließen, da unverschlüsselte Verbindungen erst gar nicht unterstützt werden. Wenn jemand Ahnung von der Materie hat, ist es das Team hinter Uberspace ;-)

jetzt erklär mir mal bitte genau wie du als Kunde(?) 100%ig ausschliessen kannst, dass die jungs - auch wenn sie noch so super sind - keine Fehler machen?
  • Forum-Beiträge: 509

04.06.2012 20:18:05 via App

Jörg V.
TLS = Weiterentwicklung von SSL seit der Version 3.0 (TLS = Transport Layer Security)

Problematisch dabei ist, dass einige Webserver und/oder Firewalls die terminieren, diese neuere Variante des SSL noch nicht unterstützen bzw. möglicherweise TLS dort nicht eingerichtet ist. Das kann einzelne Server oder im Fall einer davorliegenden Firewall ganze Dienste-Farmen betreffen.

Die Meldung " TLS erforderlich aber nicht von Server unterstützt" weist genau auf diesen Umstand hin. Die Tatsache, dass ein anderer Account, des selben Anbieters konfigurierbar ist deutet eher darauf hin, dass dort keine gemeinsame Firewall für die SSL-Terminierung zuständig ist, sondern die Server dieses Protokoll selber bereitstellen müssen.

Was in diesem Fall, bei dem betreffenden Server für den betreffenden Account wohl nicht der Fall zu sein scheint.

mal ne dumme frage: wieso sollte die Firewall die tls anfrage selber annehmen, verschlüsseln und die Kommunikation zw Client und Mailserver so verbinden? das würde ja bedeuten, dass die komm/das routing oder portforwarden bei nat zw. Mailserver und Firewall unverschlüsselt und zw Firewall und Client verschlüsselt wird?
kann ich mir nicht vorstellen...

eher glaube ich, dass der hoster u.u. tls/ssl separat pro kundendomain macht und hier etwas nicht stimmt...?

@jojo: wäre interessant was es war (im falle gefunden) und du es fachkundig posten könntest... man lernt ja nie aus

— geändert am 04.06.2012 20:19:58

Gelöschter Account
  • Forum-Beiträge: 5.215

04.06.2012 21:06:44 via Website

@Dirlan
Das ist bei mittleren bis größeren Farmen eine nicht unübliche Vorgehensweise, da so nur ein einziger Server mit einem externen Zertifikat versorgt werden muss. Die aussenliegende Terminierung der SSL Zugriffe erfolgt so an einer einzigen, zentralen Stelle.

Das muss andererseits aber in keinster Weise bedeuten, dass die nachfolgenden Weiterleitungen auf die dahinterliegenden Server unverschlüsselt erfolgt! Es kann sein, dass es unverschlüsselt ist, aber in der Regel wird da schon verschlüsselt.

lg Voss

  • Forum-Beiträge: 8

04.06.2012 21:18:19 via Website

Dirlan
jetzt erklär mir mal bitte genau wie du als Kunde(?) 100%ig ausschliessen kannst, dass die jungs - auch wenn sie noch so super sind - keine Fehler machen?

Weil ich mit den Jungs in Kontakt stehe und daher einen Fehler ausschließen kann.



Dirlan
@jojo: wäre interessant was es war (im falle gefunden) und du es fachkundig posten könntest... man lernt ja nie aus

Es lag an diesem Android-Bug, um es mal in Kürze zu schreiben. Eine genauere Fehlerbeschreibung und -behebung folgt in Kürze in einem Blogartikel, den ich dann hier verlinken werde!
  • Forum-Beiträge: 509

05.06.2012 08:03:31 via App

danke für beide rückmeldungen. ich verwende kaiten als mailclient und habe Null Probleme.
und meine mitarbeiter und Kunden haben mit htc, Samsung und sony original Mail clients auch keine Probleme...
  • Forum-Beiträge: 8

13.06.2012 17:34:28 via Website

Moin zusammen,
ich komme leider jetzt erst dazu, die Lösung hier zu posten. Hier gibt's den Blogeintrag!
  • Forum-Beiträge: 509

25.06.2012 00:48:42 via App

Jojo S.
Moin zusammen,
ich komme leider jetzt erst dazu, die Lösung hier zu posten. Hier gibt's den Blogeintrag!

danke noch für die Infos.
was ich aber wirklich nicht verstehe ist, dass wir und keiner unserer Kunden jemals solch ein Problem mit mdaemon, unserem immer verwendeten Mailserver, und seinen androiden (zig verschiedene Hersteller und Versionen) hatte...?

— geändert am 25.06.2012 00:49:28