Samsung Galaxy Note — Einige Bilder werden in der Galerie nicht angezeigt: GELÖST

  • Antworten:13
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 601

01.01.2012, 12:24:30 via Website

Ausgangslage:
==> ein Note, gerootet, dann kürzlich auf die neueste Firmware per OTA upgedatet.
==> Root bleibt erhalten ansonsten alles okay.
==> Galerie-Daten auch schon mal entfernt und bereinigt.
==> Gerät neu gestartet.
==> über CWM den cache geleert...

Gestern fiel mir folgendes auf:
normalerweise findet man sämtliche Bilddateien auch in der Galerie. Das klappt auch wenn ich mit der Kamera fotografiere oder einen screenshot mache, also alles völlig okay.

Nun habe ich gestern aber zusätzliche Bilder per PC und USB-Verbidnung (USB-Speicher verbinden ==> Wechseldatenträger) in einen Ordner kopiert, der auch bisher schon vorhanden war und ebenfalls Bilder enthält.
Diesen Ordner nutze ich ständig für das Hinzufügen von Bildern z.b. weil ich sie für die Arbeit brauche.
(Sind meist nicht mehr als 20 Bilder drin)
Bisher wurden sie dann auch immer brav in der Galerie angezeigt, egal wann und wie ich sie hinzugefügt hatte. Hatte ich Bilder gelöscht, wurden sie auch in der Galerie entfernt.
So soll es ja auch sein...

Gestern habe ich das also wie immer gemacht, nichts gelöscht, nur ein paar Bilder hinzugefügt.
Jedoch wurden diese ab dann nicht mehr in der Galerie angezeigt. Im Astro-Dateimanager und auch in "Dateien" werden sie ordungsgemäß angezeigt.
Man kann sie dort auch öffnen, allerdings dauert der Ladevorgang eines Bildes sehr viel länger, als bei der bereits vorhandenen.

Ich bin nun mal davon ausgegangen, daß die neuen Bilder beim automatischen Medienscanning nicht gefunden wurden.
Laut infos in anderen Foren habe ich dann mal die Daten der Galerie entfernt und anschließend das programm SDrescan (aus dem market) gestartet, welches ein manuelles Medienscanning startet.
im Gegensatz zu den Erfolgsmeldungen in anderen Foren tut sich bei mir jedoch nix.

Ich habe mir nun einmal die app "QuickPic" installiert, die auch eine Galerie darstellt. Die Aufmachung finde ich persönlich sogar besser als bei der originalen Galerie und dort funktioniert auch alles wie es soll. Ich werde die App weiternutzen.

Aber dennoch bleibt die Frage wo mein Note das Problem hat. Da mit QuickPic alles funktioniert, gehe ich mal von einem Galerie-Problem aus und nicht von einem Problem, das durch Rooten und Update entstanden ist.

Habt ihr Ideen dazu ???

— geändert am 06.01.2012, 22:38:10

Antworten
  • Forum-Beiträge: 601

01.01.2012, 12:42:58 via Website

ja, habe ich mehrfach gemacht....(siehe ausgangslage, ganz oben im Thread)

was mir aber noch auffällt:
ich habe mir quickpic installiert und nutze derzeit dieses.
dabei habe ich gleich noch mal die ordner ein wenig umstrukturiert und einiges an bildern usw. verschoben.
wird auch alles so angezeigt.
in der galerie jedoch ist die struktur noch immer dieselbe und die vorhandenen bilder werden sogar angezeigt obwohl sich der eingentliche pfad zum bild ja geändert hat (Beispiel: einige Ordner und Bilder habe ich von der internen sd-card auf die externe verschoben).
die müßten ja eigentlich weg sein bzw. anders geordnet. dennoch ist alles wie zuvor.
ich schätze mal, daß die galerie einfach nicht aktualisiert, warum auch immer.
wenn ich die daten der galerie einmal lösche und dann öffne sind später wieder neue daten vorhanden.
keine ahnung wo ich da der datenbank noch auf die sprünge helfen könnte....:smug:

Antworten
  • Forum-Beiträge: 2.758

01.01.2012, 13:19:00 via Website

Nutze QuickPic auch und finde die App wesentlich besser als die normale Galerie.

Lösche doch mal den Cache (CWM, Wipe dalvik cache), damit der neu aufgebaut wird. Evtl. klemmt´s dort.

Samsung Galaxy Note, thx 2 androidpit.de

Antworten
  • Forum-Beiträge: 601

01.01.2012, 13:47:43 via Website

gerade gemacht, hat leider nichts gebracht.....

irgendwoanders müssen die werte/daten für die galerie gespeichert sein, sonst würde sich ja mal was ändern, auch wenn man bilder löscht.
tut sich aber nix, ach wenn man in den anwendungseinstellungen die daten löscht.
das verwirrt mich ein wenig, normal müßte dann die galerie meiner auffassung nach leer sein, wenn kein neues medienscanning ausgeführt wird.
aber anscheinend holt sich die galerie die daten noch von irgendwo anders her....

also, ich werde auch weiterhin quickpic nutzen, aber interessieren würde es mich schon wo der fehler liegen könnte....:smug:

PS: wenn man googlet bekommt man das gefühl, daß so einige samsung-nutzer das problem haben...nur keine lösung....>_>

— geändert am 01.01.2012, 14:25:33

Antworten
  • Forum-Beiträge: 136

05.01.2012, 22:30:40 via App

Nimm doch mal die Karte heraus und starte das Note neu. Was passiert beim/nach dem scanning? Wenn die Datenbank neu geschrieben wird liegt es vielleicht doch an der Karte? Jetzt noch einmal die Karte hinein und neu starten. Klingt zwar simpel, aber vielleicht hilft es der Datenbank auf dir Sprünge? Mir ist das ganze System kurz nach dem Starten hängen geblieben, bis ich auf das Medienscanning aufmerksam wurde. Es lag echt nur an meiner Karte. Mein Note und auch Android waren gesund. Gruß anhaltmike

...mich gibt's nur mit Note...

Antworten
  • Forum-Beiträge: 601

06.01.2012, 09:28:28 via Website

auch das bringt keinerlei änderung....

an der karte liegt es somit nicht. auch sonst hat sich nichts weiter getan, aber ich nutze seit dem problem die app quickpic und mit der läufts einwandfrei.
ich tippe darauf, daß die galerieapp irgendwo ein problem hat, zumal in anderen foren dieses thema auch mit anderen samsung-phones besprochen wird. aber auch noch ohne brauchbare lösung...

Antworten
  • Forum-Beiträge: 136

06.01.2012, 19:06:27 via Website

Mist. War nen Versuch. Kann man den nicht bei Samsung die eigenen Apps laden? Ansonsten dürfte nur das Erscheinen des ICS Abhilfe schaffen. Ein Backup deines Laufwerks hast du nicht?

...mich gibt's nur mit Note...

Antworten
  • Forum-Beiträge: 11.132

06.01.2012, 19:18:50 via Website

Wenn es so schlimm ist...Werksreset, den Rest hast Du ja schon durch. Da ist dann QuiPic schon die einfachere Lösung.

Natürlicher Verstand kann fast jeden Grad von Bildung ersetzen, aber keine Bildung den natürlichen Verstand. Arthur Schopenhauer App Reviews nach Einsatzzweck und hier noch das: Das-AndroidPITiden-Buch

Antworten
  • Forum-Beiträge: 601

06.01.2012, 20:49:57 via Website

also für mich ist es nicht so schlimm, dadurch habe ich ja das um längen bessere quickpic gefunden.
von daher ist es nicht weiter wild ob sich die androidgalerie nun aktualisiert oder nicht.

schick wäre es in der tat, wenn man diese original android apps neu installieren könnte.
aber nur für die galerie mache ich jetzt keine großen faxen am gerät, läuft ja ansonsten einwandfrei....:grin:

Antworten
  • Forum-Beiträge: 601

06.01.2012, 22:26:15 via Website

update und lösung des (meines) problems:

irgendwie ließ mir das ganze keine ruhe und ich habe mal weiter in anderen foren gesucht.

dabei stieß ich auf einen kleinen banalen hinweis:
um die galerie neu zu initialisieren reicht es nicht die daten der galerie in der anwendungsverwaltung zu löschen.
die galerie speichert dort nicht alles ab was sie zum "leben braucht".

die für das problem interessanten daten liegen mit im "medienspeicher", ebenfalls in der anwendungsverwaltung zu finden.
dort müssen die daten ebenfalls gelöscht werden.

das fiese dabei: wenn man dann die galerie öffnet, sieht immer noch alles gleich aus, weil die ansicht noch in irgendeinem systemcache liegt.
(evtl. ändert sich das, wenn man das gerät neu startet).
da hilft dann nur ein "refresh" durch ein erneutes medienscanning. und das habe ich dann mit der app "SDrescan" durchgeführt.
anschließend funktionierte wieder alles einwandfrei.
bis auf eine kleinigkeit...:grin:: ich hatte das gerät nach der prozedur nicht neu gestartet, sollte man aber machen! warum: beim löschen der medienspeicherdaten erkennt das gerät die klingeltöne nicht mehr. es rief mich jemand an, aber als klingelton wurde eine sprachmemo abgtespielt.
war schon lustig, als es in der jackentasche anfing zu brabbeln...
ich wollte daraufhin einen originalen klingelton aus der liste wieder einstellen, aber als einzige auswahl erschien "stumm".
in den entsprechenden systemordnern waren aber alle töne noch vorhanden.
daher habe ich das gerät einfach mal neu gestartet und siehe da, alle töne wieder da....

in einigen foren wurde noch angeregt die externe SD-card (wenn dort bilder abgelegt werden) zu mounten, darauf habe ich zunächst verzichtet, da es nun auch so wieder läuft...


seit dem "refresh" baut sich die galerie auch wesentlisch schneller auf als zuvor und das trotz einer größeren menge bilder als zuvor....

PS: trotzdem bleibe ich bei quickpic...:grin::grin:

PS2: so wie ich das in anderen foren herausgelesen habe und wie es bei mir auch war, tritt dieser fehler auf, wenn man bilder per USB-verbindung mittels pc ändert, löscht oder hinzufügt...

— geändert am 07.01.2012, 17:53:36

Sven S.

Antworten
  • Forum-Beiträge: 136

07.01.2012, 02:21:01 via Website

Gut zu wissen. Man weiß ja nie.
...und... Gratulation!
Danke für den Hinweis.

...mich gibt's nur mit Note...

Antworten
  • Forum-Beiträge: 11.132

07.01.2012, 08:05:07 via Website

Glückwunsch!

Hinzufügen oder löschen kann ich mir nicht vorstellen, aber das verändern der Bilder vom PC gleich auf dem Handy das geht schief. genau wie das ändern (taggen) von Musik vom PC aus. Das mit der Musik habe ich selbst durch, hat mich auch einiges an Nerven gekostet. Auf jeden Fall ist ja wieder alles ok!

Natürlicher Verstand kann fast jeden Grad von Bildung ersetzen, aber keine Bildung den natürlichen Verstand. Arthur Schopenhauer App Reviews nach Einsatzzweck und hier noch das: Das-AndroidPITiden-Buch

Antworten
  • Forum-Beiträge: 601

07.01.2012, 10:42:54 via Website

ich bin mir nicht ganz sicher, aber aufgefallen ist mir das problemchen eigentlich erst, als ich per PC ein paar bilder hinzugefügt hatte.
diese erschienen dann nicht auf dem note und das machte mich stutzig...

Antworten

Empfohlene Artikel