Sind Apps für Android 3.2 noch nicht im Market zugelassen?

  • Antworten:4
  • OffenNicht stickyBentwortet

22.08.2011 14:23:04 via Website

Hi,

ich habe heute ein Update für AppMonster Pro bei Google eingespielt.
Da Android 3.2 ja draußen ist, habe ich die App auch dafür vorgesehen.

Beim Upload bekam ich aber eine Meldung, dass die App die zulässige
SDK-Version (12, sprich Android 3.2) überschreitet.

Eine schnelle Google-Sache ergab dazu nichts brauchbares.

Was jemand dazu etwas näheres?

Danke

23.08.2011 00:43:38 via Website

Geht es um "maxSdkVersion"?
-> Einfach weglassen

Oder um "targetSdkVersion"?
-> die muss nicht auf dem Maximum stehen, damit neuste Systeme die App sehen können.

23.08.2011 00:50:31 via Website

Die App ist für API lvl 13 (Android 3.2) kompiliert.
Target ist 8 (eigentlich egal, ist klar) und Max hab ich auf 13 gesetzt.
Und da hat Market gemeckert.

Der Grund war der, dass Kunden gemeldet haben, dass die App mit 3.2er Geräten nicht sichtbar ist.
Ist auch klar, davor stand max auf 12.

Jetzt scheint ja alles zu gehen. Es hat mich wie gesagt gewundet, dass Market bei max=13 meckert,
obwohl ja der SDK draußen ist.

23.08.2011 01:32:22 via Website

Genau darum die Empfehlung, maxSDK gar nicht anzugeben, wenn du nicht einen sehr triftigen Grund dafür hast.
Ohne diese Angabe wird die App von allen Geräten >= minSDK gefunden.