K9 mail - nach installation akkuverbrauch extrem hoch

  • Antworten:20
  • OffenNicht stickyNicht beantwortet
  • Forum-Beiträge: 1

15.10.2010, 13:26:24 via Website

hallo community,

habe seit 3 tagen k9 mail am laufen mit 3 konten (google, web.de und eigene domain imap konto); klappt auch so weit so gut, die funktionen sind klasse und die benachrichtigungen, einstellungen usw. funzen auch ganz gut.
ausser bei meinem firmen acc (exchange) musste ich abstriche machen; dieser läuft immer noch mit dem android mailer parallel dazu da k9 die einstellungen für meinen exchange nicht kann, mag, ...

aber wieso ist mein akkuverbrauch so extrem angestiegen? vertragen sich beide proggis parallel nicht?

danke erstmal

Swen

Antworten
  • Forum-Beiträge: 338

15.10.2010, 14:38:01 via App

Hallo,
Welchen Wert hat du denn für die Häufigkeit der Mailabfragen eingestellt? Wenn dein Android alle fünf Minuten nachschaut, kommt er kaum zur Ruhe und nippt reichlich am Akku.

Viele Grüße
-otto

Antworten
Gelöschter Account
  • Forum-Beiträge: 609

15.10.2010, 16:16:01 via Website

Wenn du K-9 aus dem Market hast, kannst du auch mal die neueste Version installieren.

http://code.google.com/p/k9mail/downloads/list

„Im Volksglauben der Hunde sind Menschen einfach fantastisch." Alexandra Horowitz

Antworten
  • Forum-Beiträge: 832

15.10.2010, 20:40:35 via Website

hi.
also ich betreibe k9 mit 4 konten (imap push) und kann eigentlich nicht sagen, das es viel akku zieht. komme gut 2 tage hin mit dem akku. installier mir aber auch immer die neuste version von der homepage.

mfg

Nexus S http://forum.xda-developers.com/showthread.php?t=1822363"">SlimBean http://forum.xda-developers.com/showthread.php?t=1719775"">Marmite Kernel

Antworten
  • Forum-Beiträge: 1.305

16.10.2010, 00:11:31 via Website

ich hab 2 konten, seit einigen tagen muß sagen trotz der per hand abfrage ist der akkuverbrauch wirklich merkbar gestiegen, woran das liegt, keine ahnung, aber hab mir vorhin mal die neuste version runtergeladen. ma schaun wie es dann wird.

Antworten
  • Forum-Beiträge: 377

16.10.2010, 13:22:35 via App

Schaue doch mal im Akkuverbrauch oder mit der App Systempanel nach ob es wirklich K9 ist.

Antworten
  • Forum-Beiträge: 1.305

16.10.2010, 14:34:01 via Website

k9 kommt gleich nach den ersten 2 verbrauchern.. display und system....
also wirds das sein

Antworten
  • Forum-Beiträge: 832

16.10.2010, 16:23:47 via App

K9 mit 4 Konten IMAP push ist bei mir mit 2% an 8. Stelle.

MfG

Nexus S http://forum.xda-developers.com/showthread.php?t=1822363"">SlimBean http://forum.xda-developers.com/showthread.php?t=1719775"">Marmite Kernel

Antworten
  • Forum-Beiträge: 1

22.10.2010, 10:43:42 via Website

Muss mich leider anschliessen. Ich finde die Funktionen von K9 super, seit der Installation des Programms bin ich aber nur am laden. Habe auf Check alle 15 mins gestellt.

Antworten
  • Forum-Beiträge: 832

22.10.2010, 12:18:00 via Website

Marcus F
Muss mich leider anschliessen. Ich finde die Funktionen von K9 super, seit der Installation des Programms bin ich aber nur am laden. Habe auf Check alle 15 mins gestellt.
naja da ist es ja kein wunder, wenn alle 15 minuten die konten gecheckt werden sollen. da würde jede mailapp den akku beanspruchen. warum nutzt ihr nicht imap push?

mfg

Nexus S http://forum.xda-developers.com/showthread.php?t=1822363"">SlimBean http://forum.xda-developers.com/showthread.php?t=1719775"">Marmite Kernel

Antworten
Izzy
  • Blogger
  • Forum-Beiträge: 6.929

22.10.2010, 12:28:35 via Website

Was man auch überprüfen sollte: Wie voll sind die Postfächer? Das spielt beim Sync nämlich auch eine Rolle. Wer's nicht glaubt, einfach mal den Issue-Tracker auf der Projektseite durchforsten.

Ein "zu volles" Postfach macht sich nebenbei aber auch in gelegentlichen "Freezes" bemerkbar (das Telefon scheint für ein paar Sekunden nicht auf Eingaben zu reagieren, der Homescreen scheint sich neu aufzubauen).

Also: Einfach mal schauen, wie viele (und wie große) Nachrichten da in den Körbchen liegen. Ggf. Sync auf die Inbox(en) beschränken, und den Überhang in Archiv-Ordner verschieben.

Antworten
  • Forum-Beiträge: 2

17.11.2011, 07:35:22 via Website

Hallo Zusammen,

ich musste mein Handy komplett neu aufsetzten. Da ich auch schon vorher K9-Mail drauf hatte und sehr zufrieden war installierte ich die aktuelle Version.
Doch seit dem liegt der Akkuverbrauch bei 31% durch K9. Die Einstellungen sind bei Abruf alle 3 Stunden. Vielleicht liegts ja auch am Akku. Ich habe jetzt mal K9 deinstalliert um das zu Prüfen. Ich bräuchte halt einfach eine gute Mail-App, die die Mails auch selbst speichert, da ich die Mails lösche, wenn ich sie mit dem Laptop abgeholt habe. Gäbe es dazu eine Alternative, wenn sich meine Befürchtung bestätigen sollte?

Gruß
Michael

Antworten
  • Forum-Beiträge: 33.139

17.11.2011, 07:44:49 via App

Eine relative Angabe wie "31 Prozent" sagt nichts aus.

Selbst ein extrem stromsparender Prozess kann hier hohe Werte haben, wenn er so ziemlich der einzige Prozess ist. Und fette Stromfresser können niedrig liegen, wenn viele andere Prozesse im Referenzzeitraum aktiv waren...

Gruß
Carsten

Ich komm' mir langsam vor wie jemand, der ich bin // #cäthe

Antworten
  • Forum-Beiträge: 2

17.11.2011, 15:17:40 via Website

hallo Carsten,
ist schon klar, weshalb ich ja auch einfach mal K9 deinstalliert habe um das genauer zu eroieren.
Bis jetzt ist, obwohl ich heute wesentlich mehr telefoniert habe als sonst und keine weiteren Änderungen neben der Deinstallation gemacht habe
und auch im gleichen Gebäude / Stockwerk unterwegs bin wie immer, mein Akkustand immer noch bei > 70 %.

Gestern war er schon zwischenzeitlich an der Ladestation zum tanken.

M. E. muss es etwas mit K9 zu tun haben, dass das Teil auf einmal so durstig ist.
Gruß
Michael

Antworten
  • Forum-Beiträge: 49

19.11.2012, 10:31:06 via Website

Hi,
ich habe diesen Thread mal wieder Aufleben lassen weil ich ebenfalls vermute, dass K9 auf einmal sehr Batteriehungrig geworden ist. Soweit ich weiß habe ich keine neuen Programme installiert oder irgentetwas an meinem S3 verändert. Trotzdem ist mein Akku fast doppelt so schnell am Ende wie vorher. Ich habe die Version 4.200 installiert (macht es glaube ich automatisch). Abgeholt wird alle 15min. (2xPOP und 1xIMAP Konten gemischt).
Ich weiß, dass Pop Konten den Akkuverbrauch durch K9 eventuell mehr belasten, aber wie gesagt, vorher war es bei weitem nicht so extrem.
In der Akkuanzeige liegt K9 immer zwischen 30% und 60%. (als nächstes kommt die Bildschirmanzeige mit ca. 36%)
Ok, laut Carsten sagt es nicht viel aus, aber es ist die einzige Info die ich z.z. bekommen kann.
Gibt es ein besseres programm das einem einen Überblick über batteriehungriege Programme gibt bzw. hilft beim herausfinden derer?
Zudem sagt mir die Anzeige, dass mein akku, bei 2,5h laufzeit mittlerweile fast 40% abgegeben hat.
Zuerst gemerkt habe ich das ganze, als mein S3 ständig sehr warm war wenn ich es aus der Hosentasche holte!
Da ich jetzt mal mehr auf die Anzeigen achte ist mir aufgefallen, dass die beiden Pfeile (grün/orange) unter der WLan oder auch GSM Anzeige ständig aktiv sind und sich kaum noch ausblenden.
Zum Glück habe ich 3 original Akkus und einen mit 4500mAh.
Bin aber über jeden Tip dankbar!

Gruß
Christian

Antworten
Izzy
  • Blogger
  • Forum-Beiträge: 6.929

19.11.2012, 18:07:19 via Website

Ich habe k9 schon seit Jahren im Einsatz (mit 3 IMAP Accounts). Bei den Verbrauchern taucht die App höchst selten auf. Schlechte Netzwerk-Verbindungen können hier jedoch den Verbrauch durchaus in die Höhe treiben.

Für das Aufspüren von Übeltätern wäre BetterBatteryStats einen Blick wert (zum Testen vor dem Kauf: Bei den XDA-Devs suchen, da gab's das irgendwo zum Gratis-Laden). Ausschau halten insbesondere nach Wakelocks (das sind die Teile, die das Gerät "auf Trab halten" und am Runtertakten/Schlafmodus hindern).

Antworten
  • Forum-Beiträge: 49

25.11.2012, 14:14:00 via Website

Hi,
der hohe Akkuverbrauch ist auf jeden Fall auf K9 zurückzuführen! Ich habe den Task gestoppt und mein Akkuverbrauch war sofort bedeutend geringer.
Danach habe ich dann mal etwas an den Einstellungen herumgefummelt.
Also, die einzige Möglichkeit die ich gefunden habe um K9 weiterhin mit moderatem Akkuverbrauch zu betreiben ist, die Push Funktion meines IMAP Konto zu deaktivieren. Das ist zawar nicht im Sinne des Erfinders, aber eine andere Möglichkeit sehe ich hier nicht.

Wie gesagt habe ich 2 POP Konten und ein IMAP.
Wenn ich die Push Funktion aktiv habe, zeigt mir das Onlinesymbol oben rechts ständig Traffic an und mein S3 wird dann sehr warm.
Ich weiß, dass POP und kurze Abhohlintervalle den Akkuverbrauch erhöhen, aber das war bis vor einer Woche noch im relativ grünen Bereich und für mich ok. Nur seit Freitag letzter Woche war es eben so, dass, ohne das ich etwas verändert hatte, der Akkuverbrauch so hoch schnellte, dass teilweise nach ca. 6h schluss war. Die Version 4.200 müsste schon länger auf meinem S3 sein, bzw habe ich eh nicht gemerkt dass es sich upgedated hat.

Der Mailserver bei dem ich per IMAP meine Mails verwalte ist der in unserer Firma. Kann es sein, dass dort eine Einstellung falsch ist, sodass ständig ein Push Signal erfolgt (oder wie auch immer das funktioniert)?

Christian

Antworten
Izzy
  • Blogger
  • Forum-Beiträge: 6.929

25.11.2012, 14:33:01 via Website

Dass der Akku-Verbrauch mit Push-Mail etwas höher ist, kann ich auch aus meinen Erfahrungen bestätigen. Wenn Dir eine Aktualität von 30 Minuten reicht, solltest Du besser auf "Polling" umstellen -- das geht auch bei IMAP. Wo genau der "Break-Even" liegt, habe ich allerdings nicht eruiert.

Antworten
  • Forum-Beiträge: 49

25.11.2012, 15:31:13 via Website

Evelyn C.
Probier doch spaßeshalber mal Aqua Mail, das ist ein hervorragendes Email Programm. Schau mal, ob du damit die gleichen Probleme hast. Nur mal so als Tip am Rande.

Habs mal installiert! Sieht erstmal ganz gut aus. Werde berichten wenn ich IMAP und pus aktiviert habe!

Christian

— geändert am 25.11.2012, 15:31:35

Antworten

Empfohlene Artikel