Uses SDK

  • Antworten:5
  • OffenNicht stickyBentwortet

Gelöschter Account

17.06.2010 21:11:45 via Website

Hallo,

ich schreibe eine Android App für targetsdkVersion="7" und möchte diese eine minsdkVersion="3" zuordnen jedoch bekomme ich immer den Fehler, dass der MinSdk Wert unter dem gesetzten sdkwert ist was mache ich Falsch??

1<?xml version="1.0" encoding="utf-8"?>
2<manifest xmlns:android="http://schemas.android.com/apk/res/android"
3 package="de.eTCG.app"
4 android:versionCode="7" android:versionName="0.7">
5 <application android:icon="@drawable/icon" android:label="@string/app_name">
6 <activity android:name="eTCG"
7 android:label="@string/app_name"
8 android:configChanges="keyboardHidden|orientation">
9 <intent-filter>
10 <action android:name="android.intent.action.MAIN" />
11 <category android:name="android.intent.category.LAUNCHER" />
12 </intent-filter>
13 </activity>
14 </application>
15<uses-sdk android:targetSdkVersion="7"
16 android:minSdkVersion="3"
17 />
18<supports-screens android:smallScreens="true"
19 android:normalScreens="true"
20 android:largeScreens="true"
21 android:anyDensity="true" />
22<uses-permission android:name="android.permission.INTERNET" />
23<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />
24</manifest>

Grüße Alexander

17.06.2010 23:57:08 via Website

Doch. Du musst nur gegen Level 4 compilieren damit Eclipse nicht meckert. Wenn Du außer den Manifest-Tags nichts verwendest dass es erst ab Level 4 gibt, läuft Deine App dann trotzdem auf Geräten mit Android 1.5

Ist der Fehler den Du angezeigt bekommst nicht nur eine Warnung? Die kannst Du getrost ignorieren.

18.06.2010 10:24:03 via Website

Genau.

Die Empfehlung ist eigentlich immer gegen das aktuellste SDK zu kompilieren, nur so kann man seinen Usern auch die neueren Funktionen anbieten die mit neueren Android Versionen einher gehen. Also z.B. Datentransfer per Bluetooth auf Geräten anbieten die es unterstützen (also Android >= 2.0) und dennoch minsdk auf 3 lassen um dennoch Android 1.5 zu unterstützen. Natürlich muss man Methoden die erst ab einem höheren APi Level existieren entsprechend absichern (Stichwort: NoSuchMethod Exception).
Auch das schieben der Anwendung auf die SD Karte (ab Android 2.2) geht ja erst wenn man gegen das entsprechende SDK kompiliert und es im Manifest erlaubt.

Bye
Lars